Console button just opens a black window?


#1

Hey! All the “console” does for me is showing a black thing… Is this a known issue? Also, how do I solve it? :slight_smile:


#2

Hi @JonasTheGamer can you give us a little more context? What platform are you on (mobile or desktop? which browser?)? I suspect this is the console button in the Logs pane at the bottom of the screen, but can you confirm? Do you see this the first time you open the console for a given browser session, or only on subsequent tries?

Just in case this is the issue, sometimes when you open the console pane the console doesn’t properly initialize. When this happens to me I find that clicking in the console area and then hitting the enter key will usually cause it to start up. This seems to happen mostly on subsequent attempts to open the console - rarely on the first go.


#3


When I click “Logs”, and then “Console”, to be able to enter stuff and do nano for node modules, it turns black. I just tried clicking and pressing enter, no difference.

It’s the first time in months I’m needing it, so I don’t know much about it. :wink:

Anyway, thanks a lot for your reply!


#4

Do you happen to see any errors in your browser console logs? Do you see the same thing if you open the Project Name menu, go to the Advanced menu, and select Open Console? What about in an incognito tab (there are a few extensions that interfere with the console that using an incognito window can work around)?


#5

Nope. Now I’m getting a white blank page. :expressionless:

Tried, same result.


Console Won't Open
#6

For your information, I just disabled all extensions, and now the console shows up. Although, when doing nano file, I don’t get the content. :expressionless:


#7

I was going to say that those browser console errors looked to me like wetty just wasn’t loading and that sounded like an extension problem. Since you had the same problem in an incognito window you can probably narrow it down to just extensions that you’ve allowed in incognito - if you discover which one it was I would love to know.

As far as your file content can you share your project and filename?


#8

As far as I know console uses an iFrame which may be blocked by some security extensions. I don’t have any problems with UBlock origin, and Https everywhere though.

Edit:
image


#9

Thanks. How do I close the “ticket”?


#10

No need to close it, but if you want to you can select an answer as the “solution” to the question and that will mark the topic as Solved.

Happy Glitching!