Discord.js "ERROR EACCES: permission denied" Error


I always have this problem when downloading a module
ERROR EACCES: permission denied
I how to fix this error?

How are you downloading a module? To use a package in your project we recommend adding it to your package.json file rather than from the command line.

package.json also get the same error

Let us know the project name and we’ll take a look.

Project Name: rtdbot-dashboard

Thanks - I couldn’t see the permissions errors, but you were using various packages that weren’t included in your package.json file. I’ve added these and it seems to be working ok now.

Okey, thanks for helping.

I have the same error, you can help me fix it?
project name: space-bots-list

Most of permission error is solved by

  • going to your project console.
  • run enable-pnpm
  • wait for reinstallation
  • try adding that package again.

I have the same error, Ashutosh tip didn’t worked for me, can you fix this please?
Project Name: men-bot

Hey @NikoBotDev I ran enable-pnpm in your project’s console and things appear to be cleared up. Can you please confirm?