I am getting a weird error constantly suddenly


#1

I am currently making a discord bot with glitch.com. I am using node-express. Between today and yesterday I have changed no code at all. It was working fine yesterday, but today I recently have this random error. I tried updating some of my dependencies but that did not help. Here is the error.
> /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/bindings/1.3.0/node_modules/bindings/bindings.js:96
**> **
> 8:20 PM
**> **
> throw err
**> **
> 8:20 PM
**> **
> ^
**> **
> 8:20 PM
**> **
> 8:20 PM
**> **
> Error: Could not locate the bindings file. Tried:
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/Debug/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/Release/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/out/Debug/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/Debug/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/out/Release/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/Release/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/default/better_sqlite3.node
**> **
> 8:20 PM
**> **
> → /rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/compiled/8.4.0/linux/x64/better_sqlite3.node
**> **
> 8:20 PM
**> **
> at bindings (/rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/bindings/1.3.0/node_modules/bindings/bindings.js:93:9)
**> **
> 8:20 PM
**> **
> at Object.<anonymous> (/rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/lib/database.js:4:40)
**> **
> 8:20 PM
**> **
> at Module._compile (module.js:573:30)
**> **
> 8:20 PM
**> **
> at Object.Module._extensions…js (module.js:584:10)
**> **
> 8:20 PM
**> **
> at Module.load (module.js:507:32)
**> **
> 8:20 PM
**> **
> at tryModuleLoad (module.js:470:12)
**> **
> 8:20 PM
**> **
> at Function.Module._load (module.js:462:3)
**> **
> 8:20 PM
**> **
> at Module.require (module.js:517:17)
**> **
> 8:20 PM
**> **
> at require (internal/module.js:11:18)
**> **
> 8:20 PM
**> **
> Jump to
**> **
> at Object.<anonymous> (/rbd/pnpm-volume/1935955a-52eb-483a-b53a-0357b9945110/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/index.js:2:18)


#2

Its an sqlite error ,
Maybe you got something wrng while setting up with enmap :slight_smile:
Check where u have used enmap as it is causing the error


#3

Let us know the project name and we’ll take a look.


#4

It is called scrubbot


#5

It’s back working - you had specified a nonexistent version number for the sqlite module.


#6

i am having the same error


#7

Can you let us know your project name so we can take a look @HunterWilson56?


#8

bumper

it is private but if you need an invite i can give you one


#9

also is there something wrong with https://glitch.com.faq/
Because i can’t pull it up


#10

same that i’m in on I keep getting errors


#11

Ok we had a little hiccup on the main community site @ https://glitch.com which has since been resolved, so everything should be back up from that perspective - please let us know if that’s not the case.

@HunterWilson56 the problem you’re seeing in your project has to do with the bindings for better-sqlite3, which seems to get stuck in cache somehow that we haven’t precisely figured out. If you run enable-pnpm in your console that will trigger a reinstall that should clear it up. Again, though, if it persists let us know.

Sorry for the inconvenience!


#12

thank you so much cori!