New remix, getting "missing program 'fibers.node'" [SOLVED]


#1

I’ve just remixed https://glitch.com/~slack-slash-command into https://glitch.com/~rounded-tank and without doing anything else, I’m getting the following error in the logs:

## There is an issue with `node-fibers` ##

`/rbd/pnpm-volume/ad15ea12-922c-41be-9b36-c55388c7532f/node_modules/.registry.npmjs.org/fibers/1.0.15/node_modules/fibers/bin/linux-x64-64/fibers.node` is missing.


Try running this to fix the issue: /opt/nvm/versions/node/v10.15.0/bin/node /rbd/pnpm-volume/ad15ea12-922c-41be-9b36-c55388c7532f/node_modules/.registry.npmjs.org/fibers/1.0.15/node_modules/fibers/build

/rbd/pnpm-volume/ad15ea12-922c-41be-9b36-c55388c7532f/node_modules/.registry.npmjs.org/fibers/1.0.15/node_modules/fibers/fibers.js:20

	throw new Error('Missing binary. See message above.');

	^

The error shows up every couple of seconds.

I’ve tried to run the command they show, but I then get another error:

$ /opt/nvm/versions/node/v10.15.0/bin/node /rbd/pnpm-volume/ad15ea12-922c-41be-9b36-c55388c7532f/node_modules/.registry.npmjs.org/fibers/1.0.15/node_modules/fibers/buil
d
node-gyp not found! Please ensure node-gyp is in your PATH--
Try running: `sudo npm install -g node-gyp`
spawn node-gyp ENOENT

I’m not sure if this is something I should expect with a new remix, or if I’m supposed to do something else to initialize it. I can’t find anything in the FAQ or the Forum that refers to fibers.node.

Thanks!


#2

does this help you maybe? Getting a 'missing binary' error

There are a lot more threads coming up if you just search for ‘‘node-fibers’’


#3

Yes, thanks, that seems to have done. I didn’t know what to search for other than what the error showed.