Node and Npm too old what to do now?

Discord js requirement is 15.0.0 or higher i try to install older version of all discord js , discord player
But yeah atleast 3 error after do that it waste my time like 4 hours now i reroll back to present version and hope that glitch will update version

you can use node 16 on glitch. check in the help center for how to set up your package.json for that


For anyone here wondering how to use node 16, set the "engines" thing in package.json to:

"engines": {
    "node": "16.x"

and to update the npm used for your project, click on the ‘add packages’ button, and then you can add npm from there. your packages.json will now have an extra "dependencies" entry, like so:

"dependencies": {
  "npm": "^9.8.1"

you might also need to add the @npmcli/fs package as well, because, for some reason, after I updated my node.js version to 16.x (which gave node v16.14.2 and npm 7.20.6), I started getting the following error message, preventing me from doing anything:

npm WARN deprecated @npmcli/move-file@1.1.2: This functionality has been moved to @npmcli/fs

After installing @npmcli/fs, everything started working again.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.