Pip3 Installation Error

Hello, I’m trying to setup RASA bot in glitch, which has the requirement of aiohttp~=3.5.

pip3 install rasa give the following error,

ERROR: Could not find a version that satisfies the requirement aiohttp~=3.5 (from rasa),
ERROR: No matching distribution found for aiohttp~=3.5 (from rasa)

I have also tried pip3 install -U rasa --user but getting the same error. Has anyone else also came across this issue or am I doing something wrong?

Thanks in Advance.

you can try running pip3 install aiohttp

I have tried that option but it is installing aiohttp-2.3.10 , not the required version of 3.5. :frowning:

hmmmm, give me a minute, ima check the pip docs

1 Like

ok, from the looks of it, you should use the version of rasa compatible with that aiohttp version,

okays, thanks for the help. Rasa does not have a compatible version in the recent releases.


Hope Glitch will upgrade the python version soon :slightly_smiling_face:.

same, oh, i have a bit of an issue myself rn, its on the latest post

Hey @sshniro,
Upgrading the Python version seems to solve the issue. Hence, try upgrading your Python to v3.5.3 or above. The minimum requirement for it to run needs python v3.5.3 or above.

Furthermore, Glitch doesn’t seem to support Python projects. Thus, I can’t say that latest version of Python will be added or not, since Glitch was not originally made to support Python.

Check out the Suggestions about upgrading Python to latest version on Glitch.

Hope it helps!

1 Like