Remix on Glitch not working

Whenever I click the remix on Glitch button, it starts to create a new project, but then brings up an error message. I can create new projects, but just can’t remix. I teach and am having students remix something I made, so let me know anything I can do to fix this. Thanks so much!

Could you tell me the name of at least one of the projects that you have tried to remix, which is not working? For example, I just attempted to remix ~cheerios-effect and created ~illustrious-soapwort, apparently successfully.

penguinstemplate.glitch.me is one. I even tried remixing one of my new projects and it didn’t work. I tried on multiple accounts.

I was able to remix cheerios-effect, but still can’t remix my own or other new projects I create.

Could you say which specific sequence of URLs or links or button presses are you using to remix? For example, I went to https://glitch.com/~penguinstemplate and then clicked the button below and to the right of the embed called “Remix Your Own” and then, after a short spinning sequence, saw https://glitch.com/edit/#!/inconclusive-speedwell, seemingly successfully remixed.

Or do you use the “Remix Project” button in the top left menu of the glitch.com/edit editor?

Okay so the first method didn’t work for me but the second did. So maybe I just have to do that?

Yeah the button in the embed does not work for me, but the option from the menu does.

There are two Remix buttons on the Glitch project “glitch.com/~projectname” page - one is inside the top right of the embed when it is in “view source” mode and labeled “Remix to Edit” - is that the one you are clicking on? (the other is “Remix Your Own” below and to the right of the embed).

Can you say what do you see after pressing it, and what do you expect to see? After I clicked “Remix to Edit” I saw a spinner, and then the new Glitch project in the embed.

Sorry this bug reporting business is so fussy, I want to get it actually fixed.

Okay so I’m actually clicking the fish button on the view page (penguinstemplate.glitch.me). And that isn’t working. Both of the ones from the project page that you sent me are working. It’s just remixing from the whole preview page.

If that makes sense. And when I click it, it spins for a bit, and then says “An error occurred when trying to create this project, please try again later.”

Thanks for the clear and specific bug report! I believe the bug is fixed.

Thank you so much! It’s working again.