Trying to create a .well-known page, Receiving Error 403

Not trying to do anything too complicated, just trying to create a site that hosts a /.well-known page, similar to https://example.com/.well-known/example, but any time I try to preview this page, or make a get request to it, I receive an error 403. Does Glitch not support pages/directories that begin with a ‘.’ or am I missing a setting somewhere?

2 Likes

not allowed on static sites

I haven’t seen any mention of this problem with full stack sites. maybe it works on full stack sites

1 Like

There’s actually a solution for static sites in a linked post from that first link: How to enable directories starting with "."? - #3 by Johnicholas

Thank you for linking those!

ah good point. to summarize, the solution described there is to convert the project to a full stack site. as the solution demonstrates, it’s possible to use an existing node package to act as the server program, so all it takes is some configuration to forbid specific other dotfiles.

that all is not a bad way to get .well-known working. but be aware that it’s different from havinga static site that serves .well-known.

Actually, by adding a package.json, you’re making it a non-static website! :slightly_smiling_face: