Unable to access *.glitch.me websites

I’m not able not access any of the *.glitch.me websites (mine or of other people). On my pc Chrome says the error is DNS_PROBE_FINISHED_NXDOMAIN while on my phone it says ERR_CONNECTION_REFUSED. I can still access the glitch.com website itself and the container status on my projects tells me that everything is ok.

This problem started just after I removed the .data directory from my project “cibo-aua-studenti” to clear the sqlite db, I don’t know if this can be related in some way.

1 Like

Hi @aziis98, welcome to the Glitch forum!

Errors like this typically indicate that there’s a network problem of some kind, most commonly because something on the network you’re accessing the internet from is blocking the glitch.me domain. Do you see the same problem on other networks (for example from a coffee shop or library, or from your mobile device using cellular data)?

It’s pretty unlikely that removing the .data directory from a single project would affect your ability to see other unrelated glitch.me pages. Some examples of addresses you’re having trouble with might help.

Yeah I actually tryied on my university WiFi and it works fine but it still doesn’t on my cellular data & home WiFi. (I’m from Italy)

Home IP (Fastweb): 2.231.30.89
Current phone IP on cellular data (Tre Italia): 91.252.166.207

That indicates to me that your home / cellular networks are blocking glitch.me urls, which seems … unusual to say the least. When you say that you tried on your uni’s wifi do you mean from the same device and browser (and browser extensions / plugins) that you’re having trouble with at home or was this on a different machine?

We have blocked a few individual IP addresses but none that match either of yours. I tested on a couple of Italy proxies and can confirm that I can get to glitch.me addresses from those - for example if you try to load one of the addresses in question via something like http://www.1000pips.it/awp are you still blocked?

I agree that’d be unusual, its more likely that they’ve blocked IP ranges a bit overzealously and included the glitch.me IP address ranges.

Hey @aziis98, can you let me know what your Internet Service Provider is and (even better) what DNS server you’re using? If you don’t know how to find the DNS server information if you’ll let us know what operating system you’re on we might be able to help with some guidance for that.

Hey @aziis98 and @Miky88, it would be worth contacting your Internet Service Providers (Fastweb and Tre Italia), and tell them they’re blocking glitch.me the runtime part of glitch.com, an educational programming site.

@cori I tried connecting from a glitch.me app to various Italian ISPs home pages. Its not a good test of the problem, and ironically the only ISP that failed to respond was https://www.tim.it/

Thanks, I will try contact my ISP in the following days

Got the same problem on every .me, I’m in Italy, vodafone and poste mobile

Hey folks I poked around a little but I don’t see a way for Glitch to contact Vodafone to bring this to their attention, so I think that request is going to have to come from Vodafone customers. A little googling seems to indicate that other sites have run into this problem with Vodafone recently and Vodafone customers have been able to get it resolved.

We’re happy to provide any assistance we can and we’d love to know how things progress.

I have same problem (fastweb), i have changed dns into 1111 and 8888, work in wifi but not in Lan

Hi @filpunisher, welcome to the Glitch forum!

This sounds as though you may be using different DNS settings on WiFi than on LAN. If you share a screenshot of your DNS configuration someone may be able to give some additional guidance.

This is my config Wifi (macos) and lan (win)

tnx

Is it possible that the LAN configuration tries to connect with IPv6?

@cori does glitch only serve on IPv4 at the moment?

1 Like

Hi @mishavee tnx, that was the problem, i have solved with these step in win 10,
I hope it helps somebody else too.

@cori tnx, glitch is really fantastic compliments

1 Like

Thanks for the kind words, @filpunisher; glad you got this sorted!

Yes, @mishavee, I believe we are only serving glitch.com over IPV4.

2 Likes