An all new Glitch editor

Glitch won’t tell you if the name you want is already taken, which is quite annoying. If it redirects to something that isn’t your project, that name is taken. Archived and private projects with the same name will show “can’t find <name here>”. I hope there is an update coming that will allow users to see if the project’s name is taken before you click save and redirect and all that, but for now, you just have to hope the project name you are trying to set it to isn’t taken.

Hopefully this helps.

1 Like

You didn’t finish the archive feature on the product page - it just copies to clipboard.

Thanks for reporting! This is fixed now.


when will this be fixed?


I wish you could revert to the old editor, or not have the UI so bulky and half-finished. It really sucks.


I give an example of glitch getting stuck when I create a folder after the last view customization it just introduced

When I write struct/Client/Client.js the website freezes, I have no problem with myself.

Highly agreed :sleepy:

I know right, the editor is really annoying an hard to use…

It’s better if you add the choice of changing between new or old UI, some people liked the new UI but most aren’t, so adding a button to switch is very good.

1 Like

How do I add projects to a team on Glitch? - Glitch Support (

There used to be a way to join a project when you’re in its team, a dedicated button in the editor. Looks like that didn’t make it into this new UI. Will it be coming back in the future?

If you are working on mobile when on-the-go, the only way to see the text in the editor is to click on the bottom of the screen on the preview button then click the close preview pane, which is very annoying.

that was temporary – back to not working.

@hman124 thanks for the tip. it still doesn’t work for me – i am trying odd prefixes to ensure its unique but has only worked once.

So, in the new editor, I opened the tools bar as usual,
I opened custom domains, then I clicked the little arrow to go back, it went back to the “legacy” toolbar.

This also works with the Import/Export, however, it does not open with Rewind.
It looked like this
Screenshot 2022-01-11 12.15.23 PM

This might be intentional, but I highly doubt it.

1 Like

Hi there @GAMS2 - you’re right, that’s a bug and not intentional, and the team is aware and working on it!

1 Like


Thanks for letting me know!
Hopefully you can fix it soon.

it’s just a minor bug, they probably just left in the code that makes it go back into that menu.
Should be easy to fix.

Take care,

I created 2 folders and boom, now I can’t work on my project because the folders are duplicated and it doesn’t allow me to do anything with both of them, not even change the name or delete. Please make this new editor an opt-in feature instead of forcing everyone to migrate into the new editor due to nature of new products, new products will tend to bug out, glitch out, and in worst case scenario break and prevent the user from being able to use the product entirely. Not a single big company would ever publish big changes for product unless it was tested very well by professionals and by the users that chose to opt-in. I hope this will be a lesson to the Glitch team and they won’t do this ever again and instead they will make this opt-in by either hosting it on a different URL like or by making an opt-in feature for each user.


The UI has somewhat improved but the dark theme doesn’t look finished at all.


Please finish a feature before releasing it or at least make it opt-in. I am sorry if I am being to harsh but releasing incomplete, and not properly tested product is not a way to go. I definitely like the idea of where the update is going but it’s current state is quite bad for the reasons I stated above. Also please give more control over the code editor as of right now we completely have none except the dark theme, a great way to start would be to add indention rules, font settings and custom themes. Overall this update looks very rushed.

1 Like

Oooh I just noticed this!

1 Like

Hi! I think I found a bug with the asset manager. The controls spill out of the modal as soon as the image renders and it can’t be scrolled. I’m using Chrome for Mac.
Chrome is up to date
Version 97.0.4692.71 (Official Build) (x86_64)

1 Like

Wonder what the inspiration for these was,
My interpretation:

  1. :smiley: The code is working on first attempt!
  2. I’m really annoyed, at these red boxes in devtools.
  3. I’m confused, most on why this isn’t working.
    Also why this emoji
    I get the “a fan of your youtube channel is here” vibe.

they must have done it like this

const knownColors = {
  red: true,
  orange: true,
  // ...

if (knownColors[wordFromYourCode]) {

so words like toString, constructor, hasOwnProperty, etc Object - JavaScript | MDN get detected as colors