Bot error on installing packages

Error: Cannot find module ‘express’

I have the express package, but it will still make this error in the console for no reason

Another error is
ERROR No matching version found for node.js@>=0.0.0 <0.0.1

Your top question can usually be fixed by running enable-pnpm in console.

Could you show us your package.json file?

enable-pnpm didnt work,

“//1”: “describes your app and its dependencies”,
“//2”: “”,
“//3”: “updating this file will download and update your packages”,
“name”: “hello-sqlite”,
“version”: “0.0.1”,
“description”: “A simple Node app with SQLite as a database management system, instantly up and running.”,
“main”: “server.js”,
“scripts”: {
“start”: “node server.js”
“dependencies”: {
“express”: “^4.17.1”,
“sqlite3”: “^4.1.1”,
“quick.db”: “^6.3.2”,
“discord.js”: “^12.1.1”,
“ms”: “^2.1.2”,
“fortnite”: “^4.3.2”,
“fortnite-api”: “^3.4.0”,
“fs”: “^0.0.2”,
“ytdl-core”: “^1.0.3”,
“body-parser”: “^1.19.0”,
“canvas”: “^2.6.1”,
“superagent”: “^5.1.2”,
“mathjs”: “^6.2.5”,
“moment”: “^2.24.0”,
“common-tags”: “^1.8.0”,
“simple-fortnite-api”: “^0.1.8”,
“node-opus”: “^0.3.2”,
“collections”: “^5.1.8”,
“overwatch-api”: “^0.8.1”,
“weather-js”: “^2.0.0”,
“erela.js”: “^1.0.4”,
“node.js”: “^0.0.0”,
“lavalink”: “^2.8.1”,
“better-discord-antispam”: “^1.0.6”
“engines”: {
“node”: “8.x”
“repository”: {
“url”: “!/hello-sqlite
“license”: “MIT”,
“keywords”: [

i copied those from my old bot, which has the same commands

Try this: npm i express -g. Or try to change the node version to 12.x as that is the latest version. May that not work. Try node version 10.x

But start at the beginning with installing express globally :wink:

not working what should i do ?

its because its a new project on the other one it worked

Anyone online can help please

I see you want your issues to be resolved. But I have had this as well. There is just something wrong in your code. Someone will get to you as soon as they can. Don’t rush them because then you’ll get the same like me: Being hated.

And that is no good feeling…

Glitch is a Free hosting service and everyone does this at their spare time.

I know,
Listen, I have my other bot’s project, which is the same one.
I don’t see why this one won’t work, and if im not wrong it happens every time I open a new project.

Try npm uninstall express and then npm i express

Sometimes Glitch just doesn’t do it correctly. Can happen.

Didn’t work
need 20 char

Is there any other kind of host that i can host my discord.js bot’s code on?

Try to rebuild your package.json. I though it was something like npm rebuild. But you’ll have to remove your package.json first.

Do i need to remove it all and start over? because i tried and it didnt work

Not for free… There are some hosts but they mostly require a monthly payment.

So fast? That is impossible. Yes. Delete your package.json and then try npm rebuild