CNAME return 404


Hello when i tried to set CNAME to my project using cloudflare or hostinger (my CNAME Config “test” point to “”) it always return 404 (same with, but when i use freenom domain it working fine,


Your CNAME value must be the domain you got from or if you are using Glitch’s built in custom domains.


Hi @ghofars302, welcome to the Glitch forum!

If you’re still running into this, can you provide screenshots for the relevant configuration screens so we can take a look at how you have things configured?


This settings i tried so far

I already try using thing and it return ‘not found’


If you run into a ‘not found’ error with then you have ether entered the wrong domain when registering your app or have used the wrong sub-domain in your DNS configuration.


Hi again @ghofars302, I see that you don’t have any custom domains associated with, without one configured you can’t just point a domain at your Glitch project and expect it to work - Glitch won’t know what to do with those requests which is probably why you’re getting the project not found / 404 page.

The help article at might be informational for you.