Discord.js bot not working

#1

Hello. I was coding my discord.js bot, but I’m recieving a lot of errors. Can someone help me?

Here is my code:https://glitch.com/edit/#!/warlock-gaming-bot

0 Likes

#2

Hello @TheBigerGamer,

Can you please provide us with the errors you are receiving so I and the other forum members can try help the best we can!

0 Likes

#3

I did create a remix of your project and could see the errors you were receiving!

The first problem was a bindings problem which I solved with enable-pnpm in the console!
The second problem was fixed by removing the “shard” in your package.json starts script, and removing “–harmony” from “node --harmony start.js”.

From there It was telling me the Node-Fetch module was missing so installing that module had fixed that problem!

I had noticed now that every time I made a change in the package.json file, it never seemed to install the modules but it said it was.
From there, the logs where filling with missing module errors that where listed in the package.json and I could not get any further from there, I would like @cori to take a look at the remixed project I have to see what may be causing this!

Cori, the project name is: glitter-hedge

EDIT:
@cori, My friend has just told me he is getting the same project, where a module is installed, but the logs saying it is not.

0 Likes

#4

@cori ^^ still not fixed, you know what is wrong?

0 Likes

#6

I’ve done what you said, but now I’m getting this error:

EDIT: Now I’ve got this error:

0 Likes

#7

Can you invite me to the project, I would like to help out more, you can dm me the invite link on discord! callumok2004#1234

0 Likes

#8

@cori

I tried using

rm shrinkwrap.yaml

But the console said it does not exist, and I tried again after using enable-pnpm and letting modules install which they dont seem to be doing. Can you take a look at this:
The project name is : Warlock-gaming-bot

This is @TheBigerGamer, I am trying to help him aswell!

0 Likes

#9

I took some time to look into this over the weekend and this morning, and I think there might be a couple of things going on.

Primarily, I think this project is stuck in a generally broken install state somewhere between using npm and using pnpm; this is a problem we see occasionally, and more often in projects that take a long time to run the installation, which anything that relies on node-gyp or node-pre-gyp often will do, since those tools mean that a package is being built from source instead of just being installed. Because of this situation, I think the project is running out of space during the install process and isn’t able to complete it.

@TheBigerGamer I’m going to run a few commands on your project in the backend to see if we can’t shake things loose.

2 Likes

#10

Ok, that’s done, and I think the project is in better shape on the install front. There appear to be some other unrelated issues remaining that we can discuss in another topic if you need assistance with them.

Sorry for the bother!

1 Like

#11

Thanks @cori for looking into that for us!

@TheBigerGamer, I am leaving the project now aswell as I am no longer needing to be there! Goodluck with your development!

1 Like

#12

Thanks. And thanks too @cori! I’ll create another topic for the errors that still exist.

1 Like