Domain name is already registered for Glitch


#1

I recently brought a domain for the first time (Whoo!) and I get the message "BerserkBot.xyz (The domain I brought) is already registered for Glitch. I haven’t previously registered this domain so I’m not quite sure what’s going on. Perhaps someone else used the same domain previously?

Anyways, my project name is “berserk” and my domain, once again, is “BerserkBot.xyz”.

Thanks for reading! <3


#3

Hey @MioLovesYou, this record was in an odd state. I’ve deleted it and you should be able to use berserkbot.xyz again on another Glitch project.

Hope this helps!


#4

I’d like to begin with saying that “I’m an idiot”, and “I am sorry”.

So, just read your response and was glad to hear the good news, all was well on your part, I could actually add the domain as a custom one (Hooray!). However, due to my excitement, I was a bit hasty and added it as a domain while the project was loading. This leads to the domain being registered but not registered with my project, I think?

If you could please fix this for me once more, I’d be super appreciative (Not that I’m not already). Again, sorry for being such a doofus and wasting your time.

Thank you for your time and patience. :hearts:


#5

Hey @MioLovesYou, it’s no problem. But if you want it to be associated with https://glitch.com/~berserk then you’re all set! It’s properly associated with that project now, so now all you need to do is to set up your DNS properly. There’s a pretty good chance you’ll need the “My Domain Name Registrar Needs an IP Address” portion of that document, but that depends on your registrar. The domain you’ll need to point the CNAME to (or for which you’ll need the IP address) is glitch.edgeapp.net - that will work just as well as the shw.io domain that you may or may not have gotten.

If you’re still having trouble or if I’ve misinterpreted something let me know and I’ll be happy to re-remove the custom domain.