Glitch app to Glitch app 403s

I have a Glitch app that makes an HTTP request to another Glitch app as part of it’s normal function. For some reason, starting yesterday, those calls are all returning 403s. When logging, I get the “To keep Glitch fast for everyone, inactive projects go to sleep …” message but when I curl from my own machine, I get a response every single time.

Could there be any issues with internal routing? Please let me know if there’s any other helpful information for debugging. Thanks!

1 Like

My best guess of what happened is Glitch tried to remove from pinging other projects. If you run ping in the command prompt, you will probably notice that those projects are on the same IP.

Oh I see. How can I tell the IP of Thanks for your help!

Open the terminal and run ping

I tried that myself and got as the IP.

Ah you meant the literal local ping command. I would have assumed that they have internal routing table/DNS stuff that did not match their external public IPs. My app has a different external public IP.

Even Heroku apps seem to be unable to make any requests to Glitch apps, I assume to prevent another source of pinging apps. I almost feel this has gone too far to say it’s just preventing ping services, but I support them doing whatever’s necessary to get back the previous quality of their service.