Glitch.com says that Microsoft Edge doesn't support JavaScript

heya so glitch is telling me that Microsoft edge isn’t supporting javascript when It obviously is.

Could you show us a screenshot of the message that appears saying this.

I have been using Microsoft edge since I started using glitch up till now

Hey @V3R1C0, welcome to the Glitch forum! I’ve moved your post to its own thread so we can troubleshoot here.

I’m sorry for the bother you’re running into here. Under some circumstances glitch.com might display that message because it’s running into problems getting all of the necessary JavaScript bits to your browser. Sometimes this can be intermittent when glitch.com is in the middle of some heavy-duty work, for example occasionally when we release changes to the site, but I’m going to assume that you’re still seeing the issue. Do you happen to have another browser on the same machine handy, and if so can you try it from there and verify that you’re seeing the problem in Edge and not seeing the problem in whatever other browser you have close to hand?

Hi @cori,

I have tried Chrome, but whenever I try to go into any one of my projects, it infinitely loads to no end.

always gets stuck on the loading part. so I have always used edge instead for glitch

It’s definitely a problem with Edge, as I can reproduce this error as well. Unfortunately Edge doesn’t have any site permissions for ‘JavaScript’ the only site permissions there appears to be is ‘Media autoplay’. I’d recommend you try Firefox if Chrome won’t load any of your Glitch projects. If that doesn’t work then there’s a bug with Glitch on your PC/device.

(Also don’t try IE as Glitch doesn’t support it. Also, Edge will be using the Chromium engine soon so it will work the same as Chrome).

Hey folks I was able to dig up a Windows laptop and I can reproduce this issue in Edge. I’ve brought it to the rest of the team; thanks for the reports!

1 Like