Glitch editor throws linting error on decorators


#1

Is there a sneaky method of extending/enabling/disabling certain rules on the Glitch editor lint process? I have a project which uses TSX extensions and it uses decorators e.g. @Something which isn’t understood by the linter. The project still compiles and works etc, but for new users remixing the project they might get thrown by these errors appearing.

53

Thanks in advance!


#2

I don’t know of a way, sadly. Options like /* eslint-disable */ don’t work. We really need to update our linting as it confuses quite a few new users when they encounter warnings about things that are valid.


#3

Thanks for your reply Gareth! I will wait patiently for the feature to be considered in a future version.