Glitch Workspace Space Bug


#1

Hello! I host a Discord Bot on your website for a long time. For some reason, I logged in to clean up my space using the git gc and git prune; in Console and it didn’t do nothing that cleaned up my project space as the other times. Also, I tried to install a package and because of space, it didn’t install it. In my opinion, I think that’s something that should be fixed and be taken into serious consideration. Here’s an image of my space. https://cdn.discordapp.com/attachments/497058987812978688/548984633774047239/unknown.png


#2

Hey @TehPig_YT, welcome to the Glitch forum.

My suspicion is that you’re run into problems running git prune; git gc because you’re so close to the limits of your project’s disk space - those commands themselves require some free space to complete, and you probably don’t have enough.

If you’re having to run those commands on a regular basis then you likely have files that change regularly and are filling your git repo with unnecessary commits. The “correct”, Glitch-y solution for this is to gitignore whatever files are causing the issue so they don’t continue to trigger git checkpoints and eat up space.

We have plans to offer paid options that may include increased disk space sometime in the future; if this interests you I encourage you to visit https://support.glitch.com/c/feature-ideas and vote for or create an appropriate topic.

If you let us know your project name, we can temporarily raise the disk space limit so you can address these issues.


#3

Hello Mr. Cori. Thank you for your reply! I really appreciate it. Firstly, I haven’t used a .gitignore file before so I don’t know anything of this. Also, about my project, I prefer sending the project name somewhere private, if you want to check it. Anyways, thank you for spending some time to solve my problem. There is a question, can I get some free space if I uninstall some packages?


#4

If your project is private, no one aside from folks you explicitly invite and a few Glitch staff will see your code. However, you’re welcome to send a message to me or the support_staff group or an email to support@glitch.com with your project details.

By default your project’s node_modules directory shouldn’t be consuming space in your project’s volume, but we’d have to take a look to know for sure.


#5

So, where (either Discord or Glitch) can I send you my project’s name to come and check it? (My project is already private)


#6

Also, for some reason, I did the enable-npm command in console and now it doesn’t install the packages in result of the bot being offline.


#7

You can safely share your project name here, you can email it to support@glitch.com, or you can message it to us in Discourse by opening the menu next to your avatar in the upper right and selecting Groups -> support_staff (or by clicking on my avatar) and then selecting “Message”.


#8

Hey @TehPig_YT it looks like json.sqlite is the file you need to ignore.

If you run echo 'json.sqlite' > .gitignore in the console, and then git prune and git gc you should clear out a lot of cruft. I’ve granted your project additional disk space for 24 hours in case you’re too close to full.

You’ll probably also want to run enable-pnpm to move your node_modules out of your project as well.


#9

Um. I’m sorry for telling that but I don’t understand a lot.


#10

I think I’ve done all the steps as you asked. Now, the project is ok without problems. Thanks for spending time to help me with my problem!


#11

My pleasure! Glad you got it sorted!


#12

I am so glad I found this website. Thanks to this, I can edit my projects wherever I am. I travel a lot and use different devices. So it’s the perfect editor for someone like me. If I was an advertizer, I would recommend this website with no doubt. Thanks for creating it. I’m using it since Spring. And the Staff team is very helpful and ready to solve your problems.


#13

Hello Mr. Cori. I am sending you this message because for the second time, the same error has shown up. If you could help me it would be very appreciated! Here’s a screenshot of what I get: https://discourse-cdn-sjc1.com/business6/uploads/glitch/original/2X/c/c55bec4a2ff9f86c1952b79cd4f056f81bae0642.png
I hope my problem will get solved soon. :neutral_face:

From a Glitch User,
TehPig_YT


#14

So your git directory is no longer the problem, but you’re using npm instead of pnpm, which means that all your node modules are taking up space in your project instead of using the shared module storage. Unless you have a reason to do this, I’d suggest running enable-pnpm in your project’s console, which will switch to pnpm and the shared module storage. It will also trigger a reinstall of the node modules, which may help towards resolving the error you’re seeing in the screenshot you posted.


#15

Okay. I’ll try to check it.
Checking it…


#16

Now I get a message saying that the bindings files cannot be located. :sleepy:
Any idea of how to solve this? :question:

Um…
What exactly happened?


#17

We see this error with the better-sqlite3 module on occasion, and running enable-pnpm (again) typically resolves it - we think this has something to do with the way that module caches it bindings.

I ran enable-pnpm in your project’s console again and that seems to have fixed that package back up.


#18

Also, thank you for solving the problem (again). I can’t wait to start working on my project again!