Google API not allowing as authorised domain

This was working just a week ago, but when I came back to run my google doc API boilerplater project ( I noticed it was no longer working and I’m receiving errors about an invalid redirect uri.

I tried updating the ‘Authorised domain’ from within the Google console, and for the first time I get a strange error which makes me think that it might be blacklisted by Google. This doesn’t happen for any other domain.


If anyone else is having the same issue with Google and can provide a suggested workaround it would be much appreciated. I have also reach out to Google API support by sending feedback, will re-post here if I receive a response.

How does this project relate to the ‘echo-slack-bot’ project you have listed in the authorised domains? Are you able to remove that and add ‘google-docs-api-notetaker’? Or you get that error for all changes?

1 Like

I happened to be testing ‘echo-slack-bot’ right before I took the screenshot to confirm that the issue wasn’t isolated to my ‘google-docs-api-notetaker’ project, however I’m getting the same error for any * domain


I’ve re-created this issue, and I’ve passed it on to our development team to look into. Thanks for reporting.

Hey! Running into the same issue now; has this been looked into further?

Attempting to authorize “” via the Google console. The only error I receive when attempting to add this is " Invalid domain: must be a top private domain."

Though I’m able to add “”, this doesn’t seem to work with further authorized redirect urls which use the .me

Hey @placeholder-code, welcome to the Glitch forum!

I tried working through a Remix of the project listed in the original topic and didn’t run into any difficulties, but you do need to use your project’s domain, not itself. Since is in the public suffix list now you need to use a subdomain (like your project’s address) for your authorised domain.

Can you give that a try and let us know how you get on?

Ah, that does the trick. It hadn’t occurred to me that I needed to use the subdomain - looks like I have some reading up to do. Thanks, cori!

1 Like