Is there a plan to allow exporting to private repos?


#1

When trying to export to Github, Hyperdev is seemingly unable to see my private repos.

Thanks


#2

Exporting to private repos has been implemented, but we’re still seeing some issues with it in the wild. We’re investigating those issues!

One option is to use the Download Project button under Advanced Options, and then push that to GitHub manually.

As a temporary workaround (unless you definitely don’t want what you’re working on to ever be public at all), you should be able to export to a public repo and then make the repo private.


#3

Are y’all still seeing some issues in the wild on this?

It says it is successful, but I do not see a glitch branch or any new commits to the repo.


#4

We don’t know of any problems with this currently. Are there any errors in the JS console when you try it? What project is having problems?


#5

Just noticed a 500 response on it. I tried it out on a private and public repo, also a repo within an org and within my own GH account. Same error.

auto-collector-dashboard is the project name.


Unable to export repo to Github
#6

I was really hoping to make this work before we launch a blog post about the project and feature using it with Glitch. :confused:

Any idea what could be causing the 500 error?


#7

Hi Taylor,

we would like to investigate on your issue, but we need the name of the project that is misbehaving. Our automatic tests do not detect any issue with GitHub export/import, nor my manual attempts, so it might be something related to your specific project.


#8

Project name was in my response a couple days ago. :slight_smile:


#9

Hi Taylor,

I can’t really reproduce the issue, even from a remix of your project. I might suggest you to sign out from Glitch and then in again? What happens if you do so?


#10

Also, make sure the repo you are exporting to already has files in it. Glitch cannot export to uninitialized repos. There is an option when you are creating a GitHub repository that says “initialize this repository with a README”. Make sure that’s checked, or alternatively push some commit to the repo manually.


#11

I wanted to add here for posterity that we figured out that the issue with @tbarn’s exporting seems to be a github organizations permissions issue. the project was exportable to a private repo on her account and my account, but not a private repo on her job’s organization.

i suggested that in the meantime she can keep the repo on her personal account and make PRs to an organization one as a means of keeping glitch part of the maintenance workflow if she were unable to get the proper permissions in the organization.