Please run "npm install" again! Package "transliteration" is missing

Somehow, the logs are saying that I have to install a package, but it is already installed…
And when I run the command in the console, it just keeps on returning the same error.

{
  "name": "AdhubModMail",
  "version": "1.0.0",
  "description": "",
  "license": "MIT",
  "main": "src/index.js",
  "scripts": {
    "start": "node src/index.js",
    "text": "echo \"Error: No test specified\" && exit 1",
    "lint": "./node_modules/.bin/eslint ./src"
  },
  "dependencies": {
    "eris": "^0.10.1",
    "humanize-duration": "^3.20.1",
    "transliteration": "^2.1.5",
    "json5": "^2.1.0",
    "express": "^4.16.4",
    "mime": "^2.4.3",
    "moment": "^2.24.0",
    "public-ip": "^3.2.0",
    "tmp": "^0.1.0",
    "uuid": "^3.3.3",
    "knex": "^0.19.3",
    "sqlite3": "^4.1.0"
  },
  "devDependencies": {
    "eslint": "^5.6.0"
  }
}

npm install transliteration -f isn’t working.

By default Glitch uses pnpm, instead of npm, and should be installed from the packages.json entry.

What is the error and what is the code that causes it?

The error is the title of this thread, and the code that causes it I don’t know… Because it’s thrown from the package I think.

What result do you get from trying with pnpm?

I’m not sure exactly how things are setup, hopefully when he comes on, @cori will have more insight.

Mkay, thanks for your support anyways.

1 Like

Hey @Jarvo if you’re having installation-related problems (which it sounds like you might be) running enable-pnpm in the console typically resolves them by kicking off a new installation. You’ll want to watch the logs carefully to see if any errors pop up during the installation.

If that doesn’t help please provide your project name and someone may be able to take a look.

I recently did that, now hoping if it works…

New error: Error: Cannot find module 'transliteration'

That seems like an error your code might throw after an unsuccessful installation. Did you see any error messages during installation?

Yes, after the installation, it’s saying ERROR ENOENT: no such file or directory, chmod '/rbd/pnpm-volume/9ac8312c-2284-4b48-a520-f310001dbc9a/node_modules/transliteration/dist/bin/transliterate

But on another bot I made, it is not showing that error, while it has the same package.

I ran enable-pnpm in this project’s console and everything appeared to install properly and I’m not seeing any error messages. I think you may just have run into different installation problems on different installs.

Let us know if you have further problems.

You fixed it… But, what the… Ugh, the project probably hates me.

It’s fixed now. Thank you so much!

1 Like