Random permission errors out of nowhere?

Hi, I was working on a new project, and jumped into one of my other projects (which was working absolutely fine) to copy some code over, and found that for some reason it was throwing errors? It says it can’t find the node-fetch module, but if I swap that line with another of the includes, it says that’s the issue instead. I tried “rewinding” it to see if I’d accidentally changed some code, and it didn’t change anything.

Any ideas? I cannot seem to find any relevant help online that seems to work. Thank you in advance!

ERROR  EACCES: permission denied, open '/rbd/pnpm-volume/db542f80-3fb4-427c-9f1a-d5b4dcaca42f/node_modules/point-of-view/package.json'

internal/modules/cjs/loader.js:613

    throw err;

    ^

Error: Cannot find module 'node-fetch'

Require stack:

- 

    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:610:15)

    at Function.Module._load (internal/modules/cjs/loader.js:526:27)

    at Module.require (internal/modules/cjs/loader.js:666:19)

    at require (internal/modules/cjs/helpers.js:16:16)

at Object.<anonymous> (

:15)

    at Module._compile (internal/modules/cjs/loader.js:759:30)

    at Object.Module._extensions..js (internal/modules/cjs/loader.js:770:10)

    at Module.load (internal/modules/cjs/loader.js:628:32)

    at Function.Module._load (internal/modules/cjs/loader.js:555:12)

    at Function.Module.runMain (internal/modules/cjs/loader.js:826:10)

I have a message along the same lines but dotenv is mentioned. I didn’t change the site I think there is something wrong with the Glitch “loader”.

I followed up to my report which is that I set up a new project, imported from GitHub (that’s why it is good to have an offline copy of the latest software), copied two database files (good to have periodic backups of those as well) and it built and is running without issue.

Good luck…

I’m not sure about how to do the importing from GitHub bit, but I can try and do it in a new project, maybe.

I thought I’d try uninstalling and reinstalling the packages but got this error;

npm ERR! path /app/node_modules/point-of-view/npm-shrinkwrap.json
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall open
npm ERR! Error: EACCES: permission denied, open '/app/node_modules/point-of-view/npm-shrinkwrap.json'
npm ERR!  [OperationalError: EACCES: permission denied, open '/app/node_modules/point-of-view/npm-shrinkwrap.json'] {
npm ERR!   cause: [Error: EACCES: permission denied, open '/app/node_modules/point-of-view/npm-shrinkwrap.json'] {
npm ERR!     errno: -13,
npm ERR!     code: 'EACCES',
npm ERR!     syscall: 'open',
npm ERR!     path: '/app/node_modules/point-of-view/npm-shrinkwrap.json'
npm ERR!   },
npm ERR!   isOperational: true,
npm ERR!   stack: 'Error: EACCES: permission denied, open ' +
npm ERR!     "'/app/node_modules/point-of-view/npm-shrinkwrap.json'",
npm ERR!   errno: -13,
npm ERR!   code: 'EACCES',
npm ERR!   syscall: 'open',
npm ERR!   path: '/app/node_modules/point-of-view/npm-shrinkwrap.json',
npm ERR!   parent: 'app'
npm ERR! }
npm ERR! 
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR! 
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator (though this is not recommended).

npm ERR! A complete log of this run can be found in:
npm ERR!     /tmp/npm-cache/12.0.0/_logs/2021-06-12T11_51_38_133Z-debug.log

Ah! This error that cropped up from trying to uninstall that package helped me find the following thread, which suggested " enable-pnpm " and that seems to have fixed it!