"Security certificate is not trusted"

hi all, i am a designer with limited coding skills. i’d really appreciate your help in making my design secure, so that users can access it. when i link the website on instagram, it blocks users with the message “security certificate is not trusted.” i tried reading other threads on this, but lack enough knowledge to trouble shoot it.

here is the website:

thank you so much!

All Glitch sites and projects are served over HTTPS which uses a certificate that’s verified by Amazon, if that were not the case that’s when we would expect to see browsers blocking or warning you when navigating to page.

Is Instagram providing the warning or is the web browser? (If you’re unsure just post a screenshot)

Hi @j3rett! Does this only happen when linked to from Instagram or does it happen when you link to it from other places? With the instragram link is it a link in your profile?

1 Like

I checked your project and the certificate seems fine. Can you send a screenshot of the error?

1 Like

One thing to check is when you put in the URL to instagram does it have the https?

1 Like

thank you all for the quick replies! @FlantasticDan @mmcewen

it happens on mobile all within the ig app. here is the user flow:
instagram --> link in bio to my personal website --> hyper-link to glitch website

(if relevant: my instagram is www.instagram.com/j3rett)

thank you for your reply!

I think @mmcewen is right, does the link in your profile include https://? It looks like browser is sending that warning because it’s recognizing your link as insecure.

I set it as my profile link and it worked (don’t worry I took it off immediately haha). Here’s my settings:


Following the link from your personal website I was able to replicate the error and took a look at the source code of your website:

You’re linking to https://www.j3rett.glitch.me and the www is what’s giving you trouble, that’s adding a subdomain ontop of your glitch project’s subdomain. Remove that to make the link https://j3rett.glitch.me and I think you’ll be all set!


@FlantasticDan @mmcewen THANK YOU BOTH SO MUCH – y’all are ninjas! I would have never de-bugged that myself. Got it to work now. Bless you both, wish I could buy you a beer :slight_smile:

Stay safe and be well!


Hi all, I’m having the same issues and I’ve read through this thread but removing the www doesn’t seem to be fixing the glitch i’m having when clicking the link in instagram bio to my personal website. I would seriously appreciate it if you could help!!

Can you clear your cache or try in a different browser? Your browser may be remembering the incorrect certificate.

1 Like