Privacy Error when trying to open webpage

Hello,

For some reason, when I try to open my webpage, Google tells me that my connection is not private.

What is the url, if you don’t mind sharing it? It probably needs a certificate.

Edit: and where are you hosting it?

The link to the webpage is https://bedmas-calculator.glitch.me/.

I’m not seeing a privacy error. What exactly are you seeing on your end?

Make sure you’re using https:// instead of http:// like you did in the link.

EDIT: I’m seeing a few issues with your code, which may help resolve any problems, but either way they’re best practices:

  1. You don’t need type=“text/javascript” in the script tags.
  2. You shouldn’t have spaces in your markup like this -
    body style = “text-align:center;”
    This is correct:
    body style=“text-align: center;”

You can also add a style tag within the head and add:
body { text-align: center; }

I’m seeing this:


The blotted out part is the link to the project btw.

Yeah I am not sure. It might have to do with your chrome settings. Maybe try clearing out your history, quitting chrome, and starting fresh. You may need to update Chrome? Your Glitch app is displaying normally for me.

The issue rarely happens though. It happened a bit of time ago (maybe a week or so), and by the next day, it was fine.

Yeah, I’ve seen the error before myself, it’s usually when I’m hosting a site somewhere (like Netlify) and the certificate is still being set up. It could be that the Glitch app is resetting its certificate, so you’re getting the error briefly, or it’s coming from another site. I wouldn’t worry about it though, since there isn’t any private info like passwords in your Glitch app.

Hi there - is this happening when you go to a glitch.me domain or do a custom domain on a Glitch project?

Sorry for the late reply.

I don’t know anything about custom domains on Glitch so I would say it’s a glitch.me domain.