Server.js or Webpack - Gimme a break!


#1

Hi everyone,
OK so I’m trying to teach myself more about npms, git repos, webpack etc… and I’ve been downloading and trying random git repos to see if I can get them to work.

Currently: I clone a git repo, follow the guide and it runs on my localhost perfectly. - This works as expected
I create a new npm user, and publish it. - This also works as expected

Now, I change some of the code/wording… and for some reason… for the life of me I can’t figure out what I need to do to get it to show the changes. I’ve changed the copyright text from 2017 to 2018… but still no luck. I’ve updated the git repo and made changed to the package.json file to show this, together with the changes in the app / components / About.jsx - but again I can’t seem to get the changes to show when going to localhost:3000

I’m sure this is really simple, and I’m going to feel like an ass when someone points out the stupid mistake I’m making when trying to view changes… but can anyone please help.

The original git repo: https://github.com/gkoos/totaliser

So to clarify:
I cloned this repo. I followed the instructions to make it work locally. I created an NPM with a slightly different name, I changed the copyright info in the package.json file. No matter what I do, the repo shows the changes, I can pull the changes, but after I run node server.js - It still doesn’t show the changes.

Any genius able to see where I’m going wrong please?


#2

It sounds right to me. Did you change to the new directory when running server.js after the changes?