How can I update node to 14.16.10

How can I update glitch from 14.15 to 14.16.10? Updating node will fix a major issue in the code.

Is this on your own computer or on Glitch?

It is on glitch

Hi there - I’ll make a ticket and see if we can get that version onto containers soon. Do you mind sharing what the major issue is that it will fix, I’m just curious!

also is 14.17 okay in your situation or no? If we are going to add to the containers we would be adding whatever is in latest Index of /download/release/latest-v14.x/

yes, that is fine. i need anything above 14.16.10. And my major issue is that the search feature for the discord bot list wont work. It shows an error but in VSCode it works above 14.16.10. Sadly we cannot fix it until glitch updates node.

Do you mean 14.16.1 ?
14.16.10 doesn’t seem to be on Releases | Node.js
That would be quite strange unless someone is ddosing your server using the CVE from here Node v14.16.0 (LTS) | Node.js

Hello! We just updated Node 14 on containers to the latest version, 14.17.3. It should be available to projects next time they wake up or - for boosted apps - their next cycle!

2 Likes

Excellent. Thanks.

Thank You Jenn

Jenn: The npm version is still quite old and doesn’t support lockfileVersion@2. We get a warning but so far it appears to be working anyway.

Just go into package.json and change the node to 14.x

I don’t think so.

It works for me.

The npm version is dependent on the Node version you’re using. What version of NPM are you trying to use and what version of Node is your project using?

I’m not sure that is the case. I’ve been using Node 14.x since I began the project and it has been installing it as needed. Glitch warned about the version of the “lockfile” and I am sure there is another message about it. It is tied to the version of NPM but we don’t have control of the version of NPM used.

The system on my PC does and it doesn’t give a warning. When I ran it on Glitch it outputs the version of Node used (the latest as expected) and the version of NPM as follows: node v14.17.3, npm 6.14.13

On my PC it uses 7.5.6 but I see the latest online is 7.19.1. Could be some setting needs to be reset but I didn’t set anything originally.

Glitch uses pnpm not npm so that could be an issue

Just update your package.json node version to be 14.x

I don’t know if that is for me but as I mentioned the node version has been set that way since the project began. If you haven’t received the warning on your project you can’t really know if that makes it go away.

Again I have never told it what version of npm to use, I didn’t tell it to display that version. I’m just reporting what is happening, thanks.

nodejs ships with a version of npm. Download | Node.js

Latest LTS Version: 14.17.3 (includes npm 6.14.13)

that’s probably what glitch has in our containers, unless they took extra steps to give us a different version, which as far as we know, they didn’t.

npm 7 is out, and you could have gotten that locally with npm i -g npm@latest. but you can’t do a “-g” install on glitch.

that’s why I think techdude is mistaken about this, you’d still end up with npm 6.

1 Like