This project has received too many requests, please try again later

#1

This project has received too many requests, please try again later.

How to solve? I’m just working actively on my project lol.

Thanks in advance!

https://msg-verify.glitch.me

0 Likes

#2

Hey @JonasTheGamer you need to take steps to limit the number of requests your project is receiving; that message indicates your project is being rate limited per the technical restrictions.

0 Likes

#3

Yep, I have been getting these messages as well today and it is seriously annoying!

I’m trying to do research on complex development frameworks. There are a few web/api requests, but come on, it’s completely reasonable for a single person doing development.

Glitch was an amazing platform to develop on, but it can’t be taken seriously if I’m going to be forced to go grab a coffee every hour (or so).

I guess that will be my queue to switch over to the Google platform (even if there will be a tiny cost).

0 Likes

#4

Hey @Jeach I’d love to hear more about what you were doing that triggered these rate limit responses. 4000 requests per hour is around a request a second averaged over the hour and I have yet to run into that limit during my normal development workflow. Glitch.com itself is running on Glitch and doesn’t hit that many requests when I’ve looked at it.

Have you run into this problem on other projects aside from the research project you mention? Is there a project name you’d be willing to share? If we’re missing a workflow when we’re doing planning around these limitations it would be good to know, but we don’t see that many rate-limited projects.

0 Likes

#5

Hello cori,

I’ve simply been building an application on top of Angular.js (yes, the old one). I like to develop experimental frameworks and stuff like that.

When I start designing things, I don’t usually focus on optimizations or performance. I just do it and when I like what I see, I will then optimize and enhance performance.

I think the real issue at the moment is that your editor essentially triggers a complete restart of the project every single time I make a single change. So while I’m programming for a minute, the project might start 30 or so times. And each time it starts, I can probably fetch 100 js, css, html files and make a dozen more REST API calls.

So after an hour or so (often less time), I will get the ‘too many requests’ error.

Yes I’m aware that I can disable that ‘constant reload’ functionality (or at least it was a feature back in the day).

As to your question on whether I ran into this type of problems on other projects. The answer is no because many of my other projects will not make as many requests to the backend. They are mostly “front-end bound” (if you will).

I thank you for your concern.

Christian

0 Likes

#6

Hi @Jeach, it seems like what you need is a watch.json file. With that you can cofnigure which files trigger restarts and how often. You can even cancel autorestart completely. Stopping Glitch from restarting when you change certian files may go a long way, especially when used in concert with turning off Refresh App on Changes, which you’ve mentioned you’re aware of.

0 Likes