Unable to export private project to local repo


Centos 7, git v1.8.3.1
I’m try to bash:

git clone https://<my_token>@api.glitch.com/<my_project>/git
Cloning into 'git'...
fatal: Authentication failed for 'https://<my_token>@api.glitch.com/<my_project>/git/'

and i use "an empty string as the password " in GUI or bash:

git clone https://<my_token>:""@api.glitch.com/<my_project>/git

and problem is still here.

I’m looked at other topic before start this:

the string is empty but still writes about fatal authentication and nothing is cloned… pls help)
How to do this?

Cloning into local
Cloning into local

Hi @VnGNL, welcome to the Glitch forums!

We pushed some changes to the git workflow that revealed a new token that you can copy from the Advanced Options menu under your project’s name. Is that the token that you’re using? We believe that there are some issues with the new git workflow that we still need to work out specifically around private projects.

If you’re using the new git token then you should still be able to accomplish what you want using the method that Tim described in the post you referenced - specifically retrieving the authorization token from a Glitch request in your browser’s developer tools and using that while we work out the kinks in the private project git workflow.

I’ll confirm here when we believe the new workflow is handling private projects appropriately so that you can change your process to use the new token.


I can’t seem to clone my project onto my laptop using
git clone https://user-token@api.glitch.com/projectname/git
with an empty password, this shows authentication error

Exact same as this: Unable to export private project to local repo


Doesn’t seem to work for me, I used that new token and got the same error


@MayorChano it looks to me like you’re having the same problem as @VnGNL so I merged your questions; can you please take a look and verify that I’ve made the right decision?

If so I think what I described in my previous post might help you out!


Yep that’s the problem - the new tokens seem not to work for private projects. Can you try using the method that I described above and see if that works?


How would I get the token from a Glitch request in your browser’s developer tools


Oh wait I figured it out


Ok yes this works thanks!


Hey folks the Glitch team pushed an update that we think fixed this issue. If you’d like to try again using the git token from the Advanced Options user interface I’d love to know if it now works.

Let me know if you run into anything else!


I tried this and got

fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.


Cori, Thanks for the reply!
Yes, before this message, I used this particular token.

Yes, earlier I saw the token in debug … but did not notice the difference between them. Really! That token that in debug differs from the token from the Advanced Options menu.

Thank you for the clearing! Git clone earned for me.


Hey @MayorChano I see that @VnGNL has been able to use the new feature - are you still having trouble? If so would you be willing to share your project’s name so I can take a look (you can email it to support@glitch.com if you prefer to keep it private).