An all new Glitch editor


Thanks for letting me know!
Hopefully you can fix it soon.

it’s just a minor bug, they probably just left in the code that makes it go back into that menu.
Should be easy to fix.

Take care,

I created 2 folders and boom, now I can’t work on my project because the folders are duplicated and it doesn’t allow me to do anything with both of them, not even change the name or delete. Please make this new editor an opt-in feature instead of forcing everyone to migrate into the new editor due to nature of new products, new products will tend to bug out, glitch out, and in worst case scenario break and prevent the user from being able to use the product entirely. Not a single big company would ever publish big changes for product unless it was tested very well by professionals and by the users that chose to opt-in. I hope this will be a lesson to the Glitch team and they won’t do this ever again and instead they will make this opt-in by either hosting it on a different URL like or by making an opt-in feature for each user.


The UI has somewhat improved but the dark theme doesn’t look finished at all.


Please finish a feature before releasing it or at least make it opt-in. I am sorry if I am being to harsh but releasing incomplete, and not properly tested product is not a way to go. I definitely like the idea of where the update is going but it’s current state is quite bad for the reasons I stated above. Also please give more control over the code editor as of right now we completely have none except the dark theme, a great way to start would be to add indention rules, font settings and custom themes. Overall this update looks very rushed.

1 Like

Oooh I just noticed this!

1 Like

Hi! I think I found a bug with the asset manager. The controls spill out of the modal as soon as the image renders and it can’t be scrolled. I’m using Chrome for Mac.
Chrome is up to date
Version 97.0.4692.71 (Official Build) (x86_64)

1 Like

Wonder what the inspiration for these was,
My interpretation:

  1. :smiley: The code is working on first attempt!
  2. I’m really annoyed, at these red boxes in devtools.
  3. I’m confused, most on why this isn’t working.
    Also why this emoji
    I get the “a fan of your youtube channel is here” vibe.

they must have done it like this

const knownColors = {
  red: true,
  orange: true,
  // ...

if (knownColors[wordFromYourCode]) {

so words like toString, constructor, hasOwnProperty, etc Object - JavaScript | MDN get detected as colors


I can find the new rename option, but I don’t know why its so buried.
But it doesn’t actually work for me . i says its renaming but then when it tries to reload the new project it says it can’t find it.
My students are hitting the same issue.

1 Like

Yeah, that makes sense. It’s an interesting way to do it for sure.

uhhhhhh, I don’t think it’s supposed to look like this…

toggling theme fixed it.
also sometimes the bar with the filename and format button disappears and you need to zoom out and back in to fix it


yea im currently having that issue rn

1 Like

Any update on a fix for the super skinny sidebar? I’ve tried toggling the theme (which did fix the colors), clearing cache and a hard reload, zooming in/out. I’m currently resorting to editing the width in developer tools…

Update for everyone having issues with renaming projects: Glitch has updated the page to alert users if the name is already taken or if there’s some other issue with it. It works a lot better now.

When I enable the editor dark theme, all the rest of Glitch is affected by the theme.

I’m getting the hard to read text bug too

I normally enjoy and embrace updates, but this one just feels uncomfortable and I can’t quite put my finger on why… I don’t think I’m a big fan of the font change but I think I’ll actually get used to it and it won’t be a problem, but the new extra-boxy layout feels more antiquated than more modern.

I don’t like that closing the preview pane is a two-click job rather than the quick hide / show arrow it was before.

I think I like the new toolbar at the bottom, but I feel that the project settings button should also be down there.

And finally, I absolutely cannot in any way shape or form read this:


Sorry to the designers if this just sounds like pure complaints :sweat_smile: but once the kinks are ironed out I’m sure most people will be happy again!

so im not the only having this problem I cant even make it big with the cursor like normally

same here

I saw that the “Request to Join” button is back. But I was trying it last night, and I didn’t see any request pop up on the project owner’s view.

1 Like

Oh No!

New editor looks great, just got 2 major complaints about it:

  • I am working on a project with white icons and the assets folder more or less makes them completely invisible (where in the past there was a checkerboard background for transparent assets)

  • The back/forward navigation kinda breaks in the new editor too, in the old editor I can use the back/forward buttons on my mouse to navigate between files; in the new editor the back button kicks me back to my list of dashboard and b/c of weird URL redirect stuff i can’t hit the forward button to go back to my project :frowning:
1 Like