Assets no longer appear in editor


#1

I uploaded a few files to the assets folder and they seem to now be hidden from the editor view.

When clicking on the assets folder I get the following message:

No Assets Yet

Drag files from your desktop to use them in your project

I’m still able to access the assets directly via their absolute URL, so I assume they are still somewhere (unless they are just cached in your CDN?)

Any ideas? Or are assets not persistent by design?

Project name is interactionlab, if that helps.

Thanks!


#2

This is a bug. I’ve raised a ticket for the issue and we’ll try and get it resolved quickly.


#3

Thanks Gareth.

Anything that can be done to avoid this issue in the interim? Need to make
a call soon if we’re going to use Glitch this semester & this might be a
dealbreaker if we can’t reliably work around it.


#4

You can rename/remove the .glitch-assets file via the console and that will give you a new one which works.

I don’t expect you to encounter this issue again - we have half a million active projects and I’ve seen this bug occur 4-5 times.


#5

As @gareth said, but after you remove/rename the file, you should run the refresh command in the Terminal to trigger a reload of the editor files.


#6

I ran rm .glitch-assets; refresh from terminal, still getting the “No Assets Yet” message. Am I missing something?

I’m also getting a blank editor view when clicking the assets folder on occasion. Clicking back out to another file and back in seems to solve it. Is this bug on your radar?

Thanks again.


#7

But are you able to upload assets again?

Yes, it relates to the same bug I mentioned I’ve recorded above.


#8

Doesn’t look like it - getting the following message:

File upload failed. Try again in a few minutes?

Will all the original assets need to be re-uploaded?


#9

Uploading seems to work to a different project I have open here, so I assume it’s specific to this container.

Do you have a sense of what triggers this? Would be good to understand so that we can avoid it.


#10

Which project are you seeing this in?


#11

Yes, it’s just this one project but it seems to be working ok now. At least, I can see an uploaded file listed. We’ll resolve the underlying cause.


#12

@creativecomputing,
we’re working on debugging the root of what caused this issue in the first place. Can you give us more information about what you uploaded to the assets? Is it possible that you uploaded over 100mb or so of files?


#13

Project name is interactionlab.

I was able to upload files again once I removed my gitignore – the downside being that .glitch-assets and other metadata files are now pushed to GH.

There were 10 files in total, less than 10 MB in total, each file under 1MB, aside from one which was around 5.

Are you able to restore the existing files or do they need to be re-uploaded?


#14

From the terminal, you can run:

git checkout 64c4da4d4389d129b79574b521d56708f72a139c -- .glitch-assets

it should restore a previous working version of .glitch-assets


#15

That worked - thank you!

So these assets are persistent on your CDN? Or do they expire after some time?

If we don’t use a gitignore file, can we expect this to not happen again, or is there another underlying issue?

Thanks again


#16

I don’t think .gitignore is related to this issue. I do have .gitignore’s in my projects and they work fine. To be honest we still didn’t figure out why you had the issue :slight_smile: In general using git to checkout a working version of .glitch-assets and then running refresh should get you back to a working state, but if it happens again to you, please let us know! :slight_smile:


#17

Strange - I’m able to reliably reproduce it here by adding a gitignore back in. Is there something specific to this project that’s broken? If you have a look now, you can see it’s having the same issue…


#18

oh, you’re reproducing the missing file, not the “Reconnecting…” message… yeah, thanks for that, that’s an easy fix :slight_smile: We’ll release it shortly.


#19

I guess I’m still confused - the issue is related to gitignore or something else?

Again, would be helpful to know so that we can avoid confusion here – rolling things back via a git checkout is going to be non-optimal w/ beginning students.

Thanks again


#20

Sorry, it was me being silly; yes, there is a bug in our code that is triggered by .gitignore, but I’ve identified it. I’ll let you know when the fix is released so you can check if the behavior is now correct :slight_smile: