Failed to import from GitHub


Hello, I’ve been dealing with this in my project past days and still unable to utilize GitHub import that much. :no_mouth:
I’m pretty sure that I wrote the correct repo name.

1.) So I made a new project, import my files from GitHub and worked like a charm. (successful on the first time.)
2.) The second time never works.
3.) And I even received error code 500 in the console. (like >POST [url] 500)

Does anyone know what caused the issue??

Hello there,
I am not sure how to fix it due to lack of information, however, you can alternatively do the following:

Initialize a new repository on your Glitch app: git init

git remote add origin

Then you can use git fetch :

git fetch origin branch-name

One last thing, your project probably has ran out of space during import. Try to ignore the node_modules file.

Happy Glitching!

1 Like

hey @klerikdust - sorry you’re running into this. can you let me know what your project and github repo is (feel free to dm me if you don’t want those public). i’ll check and see if i have the same issue.

1 Like

I’ve tried that and still no result :frowning:

2 3

Hello jenn, I’ve sent you a dm!

Received it and I was able to reproduce the 500. I’m going to pass this onto the platform team to see what’s causing this and report back!

1 Like

ok so I was looking at the info of the failed request and in the response i see “mv: inter-device move failed: ‘/tmp/’ to ‘./logs’; unable to remove target: Directory not empty”.

the github repo you’re importing has /logs listed in .gitignore but the directory exists in that repo. If you have access to this repo, I think if you either remove /logs from the entire app or from .gitignore, you should be able avoid this conflict.

1 Like

Yes, it worked!
Thanks a lot jenn! :heart: