Glitch lagging while editing large files

While editing large files of code (300,000+ lines), it’s been lagging really hard to the point where I can’t even edit the code anymore. It’s also been disconnecting and reconnecting me constantly even when every other website works and on other WiFi networks such as my school WiFi. I forked a GitHub project and I’m trying to edit it for personal use, and I’m also an amateur coder, so I’m trying to learn. However, when I switched to a smaller file, it loads fine. Is this just going to be an issue since it’s such a large file or is there a way to fix this. The only thing I can think of to fix it is turning off autosave since I’m sure that’s what’s causing this, but I figured I would still ask.

1 Like

Hi @gagekot! Would you mind sharing your project so we can check it out?

nonchalant-dune-desk.glitch.me this is just a copy that i’m gonna start working on but it has the same problems

Edit: It’s not a memory issue, I just checked and the disk, cpu and everything else is fine. It’s also sometimes getting to the point where when I edit some stuff, it’ll just disconnect midway through and get rid of the minute of work. However, this is happening frequently when I edit more than 5 words at a time, to the point where I can’t edit at all.

Thanks for sharing. I’ve been able to reproduce the issue, but the file is very large. I’ll def pass to the engineering team for feedback, in the meantime aside from the autosave option I can only suggest splitting your code into smaller files!