Glitch now runs on iOS and Android!


#1

Hello everyone :slight_smile:

We decided to bring Glitch to iOS and Android :slight_smile: Try it out on these platforms and report any problem you have (and even if you like it, tell us how good we are! :slight_smile: )

TL;DR: Glitch on iOS works flawlessly! Glitch on Android works well but you have to use a physical keyboard or install a custom keyboard because touch-based selection does not work (we suggest the Hacker’s Keyboard).

Some additional information:

  • We replaced Ace with CodeMirror as our code editor. CodeMirror has better mobile support, it’s easier to customize, and comes with a nice set of addons. We’ll be able to add new editor features more quickly! :slight_smile:

  • iOS support is strong. Glitch works both on a touch only interface and using a physical keyboard. Try it out on your iPad! We can guarantee, it’s great!

  • Android support is good, but we unfortunately cannot support touch-based selection. This is due to some limitation at the OS level, which CodeMirror cannot overcome. But don’t fear! You can still use the editor and enjoy it. If you want a great experience, we suggest installing a custom keyboard, like the Hacker’s Keyboard, which comes with arrow keys, command keys (Shift, Ctrl, Alt, Meta) and even function keys! You can select text as you would on your computer, use the tab character, and also Ctrl+Z to undo! Of course, physical keyboards will work perfectly.

Happy coding with Glitch :slight_smile:


#2

Great! As weird as it may seem i think i have attempted writing in Gomix on iOS as often as I have attempted to write stuff using chrome on macOS, and it’s always been super tough, but i kept doing it. I’ve noticed computer engineering folks think I’m extra weird for not opening the right tool for the job but fact remains that my iPhone (se, of trumpian hands am I) on do not disturb is usually my best way to stay on a single task, and to not get overly complicated in my efforts as I’m learning.

I’ll let you know from now on if i notice issues; I kind of assumed people would suggest I use a computer if I mentioned any of the interface issues I had noticed on iOS. Like having to minimize and re focus the cursor ever time I changed cursor location, or being unable to copy and paste.


#3

Hi John,

thanks for your response! Glad you use Gomix on your iOS devices :slight_smile:

Let us know if you still get the glitches you described in your post! If possible, open a separate thread so that we can focus on it without adding to much noise to this announcement :slight_smile:

Thanks again, happy coding!


#4

I love this. Started on Gomix a few days ago and it’s so liberating to code on the go! Some feedback (iPhone 6+, iOS 10):

  • Weird keyboard bugs: Pressing on shift key turns on caps (doesn’t go back to lowercase after typing a character). Copy button on landscape keyboard doesn’t work.

  • Selecting text is a little finicky. The editor scrolls as you position the carat. Undo doesn’t work as expected on my phone either.

  • I wish there’s autocomplete like in sublime text.

  • Left-swipe to minimize sidebar—nice!

  • I wanna remix parts of a project into mine. Saves time from creating new files and copy/pasting into them.

Not having to deal with installing packages and deployment is a boon. More time for the fun parts of programming. Gomix is helping me fall in love with web development again!


#5

Thanks zxzxlch!

  • The editor scroll bug has been reported, thanks :slight_smile:
  • Autocompletion and more advanced remixing features are being considered
  • I cannot reproduce the copy button bug on my iPad, can you detail how it is misbehaving?
  • We are aware of the problem with history. Unfortunately, the iOS keyboard doesn’t send the right events to the editor, so we can’t handle it through the keyboard. We are investigating possible fixes…

Thanks for your feedback :slight_smile:


#6

About the copy button bug: when I edit code with my phone on landscape mode and select some text, the cut and copy buttons are grayed out on my keyboard. Paste works though! But undo doesn’t (e.g. trying to undo that paste).


#7

Confirmed that all is working much better than before!

One minor complaint, however — I can’t seem to type a space in the console (under Advanced Options), for some strange reason. All other charecters are captured properly.


#8

Sorry about that. Is that on iOS or Android?


#9

Thanks for taking interest! iOS, latest release (11.2 I believe).

Using a hardware keyboard — tried to use a software keyboard instead, but that also doesn’t seem to be an option. So that might be another bug report, but the no space with hardware keyboard is def a more pressing issue :slight_smile:


#10

yup this is an issue with the terminal emulator Wetty that we’re currently using (https://github.com/krishnasrinivas/wetty/pull/49), there is a potential fix but the team is currently unresponsive, so we’ll be investigating alternative solutions in the future. Maybe if you could upvote that PR it’d help though


#11

Is you mean gomix as a android app ?
If you mean using gomix aka glitch on android browser then the big issue is that I cannot use the console as when I click on it it doesn’t open my keyboard!!


#12

Yeah, unfortunately the terminal library we use does not support Android and iOS yet. But if you know of other web-based terminals that work well on mobile, let us know and we can eventually use them instead :slight_smile:


#13

You could always fork it and maintain it yourselves :fork_and_knife:


#14

We’re considering that as the nuclear option right now


#15

Good news here :slight_smile: we fixed a couple issues with our terminal: now it should work well on both iOS and Android if you have an external keyboard!

As always, let us know if you notice any issue :slight_smile:


#16

@Gareth This does not work on iPod 5th generation when I got the website with the 5th generation iPod touch the screen is just white even after waiting


#17

Glitch is only supported on the latest major versions of modern browsers. IPod 5th gen can only run up to iOS 9, and so the latest versions of Safari aren’t available.


#18

@Gareth what can I do this is the only device I have atm


#19

You mentioned elsewhere having an iPhone. What’s the scenario where you can use the iPod but not the iPhone, at school or something?


#20

Im on ios, and i cant find a browser that won’t “jump”. When I use safari, Firefox, chrome the text kinda weirdly jumps to the sides, looking glitchy and almost impossible to write. It doesn’t do that on Opera, but on opera it sometimes glitches too. Please fix, or maybe an app :slight_smile: