Glitch website not loading well on old browser


I tried today to login to my glitch project and I had blank page.

The main website works, but when I try to edit / create new project. Like 2 weeks ago it allowed me to edit projects.

It does let let login to my account.

The errors from console :


So I thought I should post this of forum.

on support.glitch. com I pressed the login Button from the top and it sent me to register a new account.

I made this new account so that I can post here.

Errors from console:


( The reason I posted it like this, was because it didn’t allowed me to add more links in the main post )


I run vivaldy 32-bit, version 1.6.689.46
( User agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.98 Safari/537.36 Vivaldi/1.6.689.46)

Nobody actually support linux32 anymore, but it works smooth on my old laptop.

And I assume nobody really wants to spend time to improve stuff for ‘ancient’ devices and OS, what I’m looking for is maybe another way to access my project files from glitch.


the Now works.


@r44 glad to hear you’re able to access your project- is everything working okay for you now?

1 Like

Everything working so well, thanks !


Guys, I have this problem again. Started like 1 month ago.

Isn’t there another way to access my files and upload/download .

Whenever i learn something new in js I come here and try to make something with what i learned, your service is well appreciated < 3

( vivaldi 1.6.689.46 )

Is your JavaScript enabled?

What browser are you using?

1 Like

@RiversideRocks vivaldi 1.6.689.46

It should work as it is chromium based…

The Main page and forum works, only the /edit/ doesn’t

yes. I haven’t turned it off.

Discord and other websites works

I would just reccomend downloading chrome, as chrome is 100% supported by glitch.

Sadly, is not working on my chrome.

Screenshot from 2020-05-08 01-21-05

I’m on Chromium and it works

That is odd. Try disabling ad block as it could be blocking an iframe.

Thanks < 3. Now works again on vivaldi