Upgrade node version and npm

Hi guys,

Whenever I start a new project or clone a repo, a node 10.x is being set and I cannot upgrade it to a latest version (16.x for example). All the methods found doesn’t work. I tried to change the engine version in the package.json and then refresh: doesn’t work. Update node through npm: doesn’t work (EROFS).

Does anyone were able to update it? If yes, how do you proceed?

Hi @sebastien.martin ,

The engines property in package.json should work. Can you show us what you’re doing to test it?

You won’t be able to upgrade Node or NPM at the terminal as Glitch containers don’t offer admin/sudo, and come with pre-installed LTS versions of Node. There is a 16.x version installed.

Hi @SteGriff

Here is the script code : Glitch :・゚✧

but when you run node -v it displays node 10.x

Edit : Now it works… It seems that it takes a lot of time to do the change but updating the package.json seems to work.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.