Issues requiring nedb

Hi guys I’m new here and must say I pretty much like glitch.com.

I started my second app (after a small highscore server used for games) yesterday and after some time I get the following error: using the nedb module (simple DB).

#My installation and usage steps:

  1. install nedb by either use terminal: +package option on top of package.json
  2. in code: const Datastore = require(‘nedb’);
  3. Error shown in Logfiles: @line const Datastore = require(‘nedb’);

#What I tried:

  1. Refresh (Terminal)
  2. terminal → npm install → error

Pls keep in mind that this worked before like a charm (i.e. in my first app and about 20min before this happend).

Does anyone has experienced a similiar issue, or am I just to dumb to see an obvious reason for this behaviour?

Regards

Note to myself: enable-pnpm!!! in Terminal seems to get rid of that issue :slight_smile: would be nice to know why tho…

1 Like

Welcome to the community @Saturn91 !
I’m sorry that one of your apps was showing a missing module error! You can find an explanation for why this occurs here.

We are working to prevent these errors from occurring in the future. In the meantime, running enable-pnpm - as you mentioned in your post - will clear the error.

1 Like