Project Suddenly Corrupted

I was editing a project in glitch and I was reorganizing my javascript and CSS files and started to make folders for them. Until I accidentally named one folder pulblic/https:/AppJS. The editor glitched out and I reloaded the page, but glitch popped up this error:

I reloaded the page again and, no luck.

I know this must be a project corruption because I went to the glitch preview of the project and tried to remix it. The NEW remixed project ALSO refused to load the error.

The project name is: project-rsa and the url is

Hey @ArstotzkaDeveloper,
Your best bet is to email glitch at
However, Glitch staff only work Monday - Friday so don’t expect a response till Monday.

If the project lets you open the terminal, you may be able to fix it yourself…

use linux command line such as

  • ls to see what folders you have
  • ls public to see what is in folder public
  • cd public to change directory to public
  • mv folder1 folder2 to rename a directory

Thank you so much! This worked. There was a rouge folder named http: which crashed glitch.

I would recommend if glitch is reading this message to add a character restricted for forbidden characters to be used in folders.

1 Like