Asset virtual folder only shows the latest uploaded asset

I’m using Safari 14.0.3 on macos 11.2.3.

I drag images from a different browser window into glitch assets. I can copy the asset CDN url and use all of them in my app, but once I have uploaded a new asset, the old asset goes away from the UI. I only see “click me to copy”, “use the URL in your code”, and the most recently uploaded asset.

This seems like a bug. if it is by design, it would be nice if there was a note saying that this is how it works right next to “use the URL in your code”.

Hi, could you attach screenshots? Also moving this to #feedback!

Hi @jrwren - I just tried this on my machine and cannot replicate this bug. Can you tell me the project you’re experiencing it with. Also, do the files you’re dragging in have different file names from each other?

1 Like

EDIT: The project I’m experiencing it with is ^^ ap-q

Some are different names, but there is a lot of image.jpeg too. I don’t really know how the magic of dragging an image from one safari window into another names files and if they are kept from their source, so maybe they do all have the same filename.

This is my first time using assets, so I’ll have to try using a different project…

I just tried and it happened on my taylor-q project too.

I wonder if the issue is dragging from safari window instead of the upload button…

INDEED! If I use the “upload an asset” button, I can see more than one asset!

What if I drag from finder…

Yup, I can see multiple if I drag from finder.

But I was trying this in a different project, because I didn’t want to upload unrelated stuff to the ap-q project. I actually have some things in finder that I’ve been meaning to upload to ap-q, so let me see…

Yup, that works too.

So it seems to happen to me only when I drag from another Safari window into the glitch safari window :frowning:

oh well, I guess I can simply NOT do that anymore. Yay for a work around.

Ah, I didn’t even know dragging an image from one browser window into another was actually possible. I’ll check this out tomorrow and see if it happens in other browsers as well and let the team know if we expect that to work! Thanks for the extra info!

2 Likes

I didn’t know how this was supposed to work until you asked me those questions.

Now I notices that yes, they are all named image.jpeg, and I’m guessing the &v={timestamp} is versioning? So my app uses lots of different versions of image.jpeg and it is all working. I guess if I ever delete that one image.jpeg, all of the versions will be deleted? Oh well, that is fine.

Interesting problem. :slight_smile: