Can't view project previews — domain can't be resolved in Italy -> Host not found!

Hello there, I started using Glitch two days ago.

All of a sudden I can’t see project previews anymore!

I can access the platform and the editor (.com), but not the previews, which I see are under a different domain (.me).

It looks like I can’t resolve the .me domain… works just fine and ANY subdomain do not work!

I tried:
with my home connection and cellular data,
in a private tab and on my phone,
with wget and traceroute!

DNS just don’t resolve the IP!

I can’t post links so let’s do XXX = any project .me URL

wget XXX
Can’t resolve IP address for host: XXX

traceroute XXX
traceroute: unknown host XXX

I’m in Italy , if that matters anyhow…
Reaching that host trough a proxy in the Netherlands works tho.

It could be some kind of DNS issue?

Hope this is of help and that you can get around this issue easily.

PS: My phone and home ISPs are different, and both did work until yesterday evening (~8PM)!

1 Like

Are sure the link is like

There are a couple of forum topics on this “Italian Issue” already, it’d be worth grouping them @cori :slight_smile:

The root cause is either of :

  • trying to access via IPv6, which Glitch doesn’t yet support on the project servers,
  • or the ISP’s DNS is not listing the Glitch servers.

A short term solution is to, on your devices or router, set a different DNS provider for IPv4, for example / and/or disable IPv6.

A better long term solution, and to make sure your site visitors don’t have the same problem, is to open a discussion between your Internet Service Provider (ISP) and Glitch support staff.

Yes. Same URL works trough proxy.

Tried pc browser, phone browser, cli, with many projects and with different networks (wifi and cellular)

Also preview inside editor does the same (where I do not type in an URL by hand)

it is an italian issue… use the dns as and secondary as
but this is not a solution, because you must do it from every device… and you cannot show the apps to other italians… without having to use a vpn or change the dns every time… so, what shall we do? For the italians it’s almost useless…

1 Like

I have tried changing the dns but it still doesn’t work on my laptop. I have tried emailing glitch about the issue and they haven’t emailed back

Does anyone have advice?

You could change to cloudflare DNS.