Could not find node 14, using 10 - error message preventing project load

Hello - can anyone point me in the right direction to solve this error message that is preventing my project from loading?

The project is “pophist-ssg-test” - an eleventy blog.

The error is “Could not find node 14, using 10”. This cropped up today for the first time. It was working fine without any package changes a few days ago.

Curiously another eleventy project on Glitch (“hanminart” that uses node 14 is fine, doesn’t get this error.

Following advice here Can I change the version of node.js my project uses? - Glitch Support ( I tried entering “enable-npm” in the project terminal, which didn’t work.

I have double checked my package syntax

“engines”: {“node”: “14”}

…which looks fine and anyway has been working without any issues for months until today.

So I am at a bit of a loss - can anyone help?

1 Like

thanks @_tr - yes everything was working fine until today, and is still working fine on my other project with node 14

1 Like

I think you wrote the version wrong, try using “14.x” instead of only “14”

See: Can I change the version of node.js my project uses? - Glitch Support

Thanks for the tip - unfortunately got the same result with the msg now “Could not find node 14.x, using 10”

1 Like

Hi there - I was able to get it to install node 16 - I’m not sure why it’s not identifying the versions of 14 we have on containers so I’ll ask the engineering team to look into that.


Thanks @jenn - that gets things working again.

1 Like

(btw my other eleventy project hanminart uses node 14 and still works fine)

yeah our starters also use Node 14 and work fine as well! :ghost:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.