GetPort: Application failed to start on container fossil-sage


#1

The logs of the app look good, but when clicking on show I get

{"status":"Error","statusCode":503,"statusDetail":"GetPort: Application failed to start on container fossil-sage"}

Any idea?
https://fossil-sage.hyperdev.space/


#2

+1 on this. BTW my port 3000 is already in use. So I changed .env.PORT to some other (3020) val but problem persists. Removing .env.PORT fixes it. Looks like the app refuses to listen to anything else than 3000?


What port does my app use?
#3

Yeah… We’ve been struggling with some load issues, and operating right around capacity since launch. The symptom is sporadic 503s, which can’t be explained by errors in your application logs. The :fire: is effectively out, but you could still see some smoke.


#4

I’m still getting the same error @nathan. Anything I can do? There is no rush of course, I know this is know and your resources are limited, but once we can deploy Hoodie apps to hyperweb, I could totally imagine it to be the perfect platform for newcomers to build their first apps on, for tutorials, show cases and bug reports. And maybe most importantly for simple apps that people just build for fun for themselves or their teams, that is exactly what we try to achieve with Hoodie :slight_smile: And hosting is an unsolved challenge yet.


#5

After this starts happening does it eventually resolve itself? I worked around it the first time by creating a new project and copying my changes over to it manually and that container was able to run. I’ve made quite of bit of chagnes now and don’t really want to copy it over again if this is something that will clear, even if it’s a matter of hours.

BTW, this is such an awesome environment! Great job!


#6

I am also having this on my instance.


#7

It does resolve itself, I’ve been getting this issue every now and then all day, usually it’s working again within 5 mins, occasionally it’s longer.

I’ve noticed that when it happens, sometimes any recent changes I’ve made get lost, so when I notice it I ctrl+c the file I was working on before trying a refresh, just in case :wink:


#8

Making a minor change to a file like package.json sometimes helps to kick things back into action.

But we’re sorry for the continuing problems with this guys - we should have some workarounds to bugs in the underlying container tech going out today that will help alleviate this.