Need help with project being corrupted


#1

Heey there!

Somehow, randomly earlier today my glitch project seemed to suddenly go haywire!
I got no clue how this could’ve happened, all i got was a message from discord in my mail that
the login attempts of my bot probably got bugged so they resetted it for me.

On response of that, when i finally got home i could check it out but to my surprise i could not edit ANYTHING
any changes i made refreshed the page and undone the changes i made. Removing files did work however but
this did not solve anything. I managed to salvage 90% of the project and move it over to a new one, but i’d still
like to see if it’s possible to fix it? And also get to know what caused it so i could perhaps prevent it!

Btw the rewind tool also got unresponsive so i did try that! Hopefully i can get some help with it :slight_smile:
the project name is “dragobot” (not to be confused with dragobot2 which i just created)

thanks in advance!


#2

Hello Can You Add Me On Discord So We Can Talk? I Might Be able To Help


#3

My Discord Is Anonymous#8246


#4

Anonymous couldn’t really help me out here, i need a dev to help me out (or someone that knows how to fully restart a project without deleting data?)

This is mostly because i don’t really trust people i don’t know into my project (there is data in there from other people trusted to me)

Thanks in advance!


#5

It sounds like your project has run out of space - see https://glitch.com/help/when-i-try-to-edit-a-project-it-just-refreshes-and-doesnt-save-my-changes/


#6

Thank you! Now i can edit my project again :smiley: however the rewind function seems to be loading infinite…
Considering i’ve ran out of space; is it even possible to rewind to an earlier state of the project?

Thanks in advance!


#7

Yes, you should be able to. Do you see any errors in the browser dev tools console when you access Rewind? If so, It would be helpful to know so we can look into why this is happening.


#8

Right, in the logs console it self it doesn’t show anything…

However if i go to the web browser console this is the following error:

jquery.min.js:4 POST https://api.glitch.com/projects/e50b0124-e19c-4113-bcc6-0f7aa3b0191a/git/commitChanges?authorization= 500 ()
send	@	jquery.min.js:4
ajax	@	jquery.min.js:4
(anonymous)	@	application.coffee:401
ajax	@	application.coffee:400
(anonymous)	@	api.coffee:23
n	@	api_generator.litcoffee:29
initRewind	@	rewind.coffee:52
(anonymous)	@	rewind-panel.coffee:69
(anonymous)	@	main.js:27
h	@	main.js:26
p	@	main.js:59
toggle	@	main.js:137
toggleRewindPanel	@	sidebar.coffee:114

and

/edit/#!/dragobot?path=server.js:15:52:1 Uncaught (in promise)

1. {readyState: 4, getResponseHeader: ƒ, getAllResponseHeaders: ƒ, setRequestHeader: ƒ, overrideMimeType: ƒ, …}

||Promise.then (async)|||
| --- | --- | --- | --- |
||initRewind|@|rewind.coffee:55|
||(anonymous)|@|rewind-panel.coffee:69|
||(anonymous)|@|main.js:27|
||h|@|main.js:26|
||p|@|main.js:59|
||toggle|@|main.js:137|
||toggleRewindPanel|@|sidebar.coffee:114|

hope this helps! And thanks for looking into it!


#9

There seems to be a problem with committing the current changes in git. You can try doing a

git add .
git commit -m "Manual commit"

at the console. You’ll probably get an error that will tell us what’s wrong.

I edited your previous post because it contained your user token. The part of the requests with authorization= needs to be kept secret.


#10

Oh thank you for the edit! I had no clue!

Further i’ve tried the requested suggestion and this is the result;

app@dragobot:~ 13:56 
$ git add .
app@dragobot:~ 13:57 
$ git commit -m "Manual commit"
fatal: cannot lock ref 'HEAD': Unable to create '/app/.git/refs/heads/master.lock': File exists.
If no other git process is currently running, this probably means a
git process crashed in this repository earlier. Make sure no other git
process is running and remove the file manually to continue.

Thank you again in advance!


#11

Try deleting the file it’s complaining about and then commit again.


#12

I just deleted the only possible file still being there which is server.js (i removed the others beforehand as an attempt to fix this)
tried the commit again but the same error comes again. :confused:


#13

Sorry - I wasn’t clear. I meant delete /app/.git/refs/heads/master.lock
You would have to do it from the console - you can’t see it in the editor.


#14

Oh i see, how can i achiev this? I’ve never really done much with the console except “refresh” or installing a module… And the git attempts from earlier :slight_smile:


#15
rm /app/.git/refs/heads/master.lock

#16

Thank you very much! After doing that and doing the commits, a refresh & now i can rewind again!

Again thank you very much <3