Project taking up too much space


#1


Please check this out moderators.


#2

Hey @RazorApple, soory you’re running into problems. Looks like your project’s git repo is taking up too much room. To resolve this:

  1. add whatever files are being changed regularly to a gitignore file. In this case it looks like it’s a couple of .txt files and some sqlite files.
  2. open your project’s console
  3. type git prune and <enter>
  4. type git gc and <enter>
  5. type refresh and <enter>

After you’ve done that you’ll have cleaned up any excess space in your project’s repo and hopefully it won’t just fill back up again.

I’ve temporarily increased your project’s volume size so you have enough time to resolve this issue; please take care of it within 24 hours when the project’s volume will shrink again.


#3

I’m so sorry, I didn’t see this. I can’t change the sqlite code file. I want to turn the sqlite and most of the api stuff offf.
I hope you’re online and we can figure this out.

edit you gave me space to change stuff ok ok ok i m going to fix

quick question, how can I make a variable global


#4

You don’t need to change the file. Just add it to a gitignore file so that it’s not being tracked by your project’s git repo (which is what’s currently eating up all your space). In your console you can run git log --stat to see a log of recent commits including filenames. In your case a .gitignore that looks like this would go a long way:

joof.txt
joofz.txt
scores.sqlite
scores.sqlite-shm
scores.sqlite-wal

As you noted I’ve increased your available space again.


#5

Thanks but, I cant seem to make discord.js work and I need to make a variable work in the whole script but how?

The code says Error: Cannot find module 'discord.js' but I have it in my package.json


#6

I really need help fixing this bot due to that this bot is on over 110 servers and 23k users

fixed it probaly
the shrinkwarp.yml was broken
fixed it by --force
oh not fixxed


#7

If you watch the logs when Glitch tries to do an install you’ll see a note about the shrinkwrap.yaml file. Generally speaking, you want to leave that file alone, but in some cases starting from a clean slate can help resolve some issues; I’d say this is one of those cases.

In your project’s console, run

rm shrinkwrap.yaml 
enable-pnpm

And let’s see if that gets you to a successful install. If so, your other immediate issue should also resolve itself.


#8

still not fixed…
please help


#9

Error: Cannot find module 'discord.js' this helped. just change it to pnpm and ur ready.