Godaddy says "Record could not be added" when trying to add CNAME for custom domain


Not sure why I can’t add the CNAME in goddady.
If the name is www or @ and the value is glitch.edgeapp.net then Godaddy says “Record could not be added”
If I put lankydoodler.glitch.me into the name section then it accepts it but after 48hrs my domain still just takes you to godaddy.
Do you still need thanks? I can’t see how to give thanks.
Or is something else wrong. This is a static site.
Thanks

Hmm that is odd considering in the docs it says GoDaddy should work. Have you tried setting up an A record instead? Adding a Custom Domain - Glitch Support

Hi there - you don’t need thanks and your settings there look correct. Is there a chance that you have another record already for this domain?

Try changing www to @ or change it to something unique like testing. That can test if your domain is already used on a different glitch project. And make sure there are no hidden spaces in front of glitch. edgeapp.net

“testing” is accepted as the CNAME name. Not sure if this works yet. I have no other glitch apps with this custom domain. Is the problem that I already have a CNAME with the name “www”(see image) and must delete it?


I found an IP for glitch and added it as as A record. This seemed to work for a few hours. If I use https://dnschecker.org/ and put in glitch.edgeapp.net I get given a bunch of IP addresses. Not sure which one to pick and why. (ie Don’t really know what I’m doing) Does this give a permanent solution or do I have to keep finding new IP addresses every few hours

Setting up a domain is supposed to be permanent, unless you change things on your end of course. Did it stop working for you after a few hours or did you attempt the CNAME instead?

If a list of IP’s is given with no differentiation, I imagine you can use any of them.

Yes, that is most likely why!!! You can not have duplicates of a domain. Your www must point to lankydoodler.com or glitch.edgeapp.net, It cant point to both.

Just delete your www record and set it to glitch.edgeapp.net

1 Like

Hey there!

I’d try changing over to Cloudflare.

Set up an account and add your domain and change the nameservers over to Cloudflare (which will tell you what they are) and you can try to see if adding the DNS record works there.`

Edit: It will also migrate any other existing DNS records that are on your domain.

1 Like

Thanks all. It worked once I deleted the default CNAME named www that godaddy puts in for you and just had name:www, value: http://glitch.edgeapp.net

1 Like

You’re welcome! I hope I solved your problem.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.