Help, I have lost around 3 hours of work - my project has not been saved


#1

I was working on a project last night. I noticed something strange, when I tried to remix, the code would rewind back about 3 hours, I stopped trying to remix. Now I come back to the project today and it has lost those 3 hours of changes. Please help me to get it back. The project is private but I will happily send you the link if that will help.

Thank you


#2

Hi @elbobo I’m sorry for the inconvenience! Yes, please send us the project url (you can email it to support@glitch.com if you’d prefer) and we’ll take a look as soon as we can.


#3

Hi Cori,

Thanks for getting back, I have emailed the project URL to that address. Any help much appreciated.


#4

We received your project name, thanks for sending that! I spent some time digging into things with our developers and we have some follow up questions:

  1. Can you tell me what timezone you’re in and when the changes you were working on that seemed to disappear were taking place? Can you clarify if they were before or after the rewind changes that show up from ~20 hours ago? We do see some project snapshots in our records and we want to see how they line up with the problems you were experiencing.
  2. While you were working and seeing your changes disappear was your app itself being updated? Did the changes that went missing showing up in your app as you were working? Basically we want to know if your changes were being saved to disk, in which case they would also show up in your app, or not, in which case they wouldn’t have.
  3. Where were you making these edits? In the full screen editor? In the console? In an embed? Somewhere else?
  4. Can you give us an overview of your workflow while you were making these changes (by which I mean a step-by-step description of your process while you were making the missing changes)?

All of this will help us figure out what’s going on.

Also while I was digging into this I undeleted one of your projects (aspiring-beat-deleted) as a reference. You can safely redelete that if you’d like.


#5

Hi,

  1. I’m in GMT. The changes I was working on that have disappeared took place between ~10pm - 1am last night (mon 12th). I’m not aware of any rewind changes that you describe, I don’t use the rewind feature.
  2. Yes, the changes were showing up in the app, I check constantly they were for the whole 3 hours that I was working on it. It was only at the end of this period (~1am) that I tried to remix and noticed that the changes weren’t being carried across to the remix, they remained and were working in this file (and I checked by viewing the project).
  3. I was making these edits in the browser editor, not sure if its the full screen one, just the standard one you are presented with when clicking to edit a project online.
  4. Overview of workflow, make changes, click to show the app, go back to edit, click to show the app, repeat, repeat. The changes I made were live in the browser many times over the period.

Thanks for your help


#6

Great, thanks for the additional detail!

I am a little confused by this part:

Are you saying that the project you sent me has the correct changes (and didn’t lose anything), but when you remixed it they didn’t show up in the remix? Or am I misinterpreting something?


#7

No, I’m saying that at 1am the project I sent you had all the changes and was running them live in the browser. I then tried to remix the project and noticed that the remixed project did not have the changes. I tried a couple of times but it wouldn’t work so I stopped trying to remix. I worked on the original project for a little bit longer then stopped. At the time that i stopped all changes were saved in the project.

Does that make sense?


#8

Well, I think I understand what you’re saying, but it doesn’t make sense with what we’re seeing on the backend, which probably just means we’re looking at the wrong things.

To be 100% sure I understand, does the project you sent us have the changes you’re looking for or not?


#9

No it does not, and I really need them back!


#10

Ok we took a look at a couple of deleted projects that appeared to have changes around that time which I have undeleted. Can you take a look at those and let us know if they contain the changes you’re concerned with? They’re peridot-jumbo-deleted and gleaming-duckling-deleted.


#11

No unfortunately they don’t have the changes. They are the projects I mentioned where I remixed from ‘silly-frown’ and couldn’t see the changes so deleted them…

If there is anyway of searching actual lines of code, from memory I made a js component called ‘dasher’ and another one called ‘simpledasher’

I also included this script in my header

<script src=“https://unpkg.com/aframe-layout-component@4.3.1/dist/aframe-layout-component.min.js”></script>

If that helps at all?

Please let me know if there’s anything else I can do, I desparately need the code back…


#12

Thanks for the confirmation; I’m afraid I don’t have any good news for you.

We have a few interrelated processes that track changes to projects and none of them are providing us with the activity that you’re missing. For instance we take a snapshot of each container at the same time that the git checkpoint that shows up in Rewind is taken, and here are the snapshot times for the project in question around the time we’re concerned with:

Mon Nov 12 2018 18:32:55 GMT+0000 (UTC)
Tue Nov 13 2018 13:45:42 GMT+0000 (UTC)

As you see there’s a big gap there that includes the time when you were attempting your remixes and noticing things had gone awry. We also don’t see any missing remixes of the project in question aside from the few you deleted. The second of the above snapshots doesn’t have a corresponding git log entry, but that probably means it was taken in response to a project shutdown instead of an edit, and is ~12 hours after you ran into the problem, so it’s doubtful that it includes the code you’d like to recover.

We’ll keep thinking about what else we might be able to do to help, but at this point we don’t have anything relevant to go on and no useful actions to take.

I’m truly sorry for the inconvenience.


#13

Thank you for trying.

Thats frustrating… is there anything I can do to avoid this happening? I like using glitch but if I can’t rely on it I might have to think of something else


#14

I understand your frustration and I wish we could help in some fashion.

Unfortunately we don’t see anything which could explain the behavior you’re describing, so I don’t have any guidance i can offer as far as what to avoid, nor have we seen this behavior in the past as far as I can tell.

If something comes to mind that either leads us to an explanation or to a resolution I’ll be sure to let you know; I just didn’t want to keep you waiting for a resolution instead of redoing your work (as terrible as that is).

Thanks again for using Glitch!