Git clone does not work! HELP!

I want to clone a repository but when loading the project I see that it is completely empty and I noticed that there was a message in logs:

Your app is taking a while to stop…
Your app did not stop in 5 seconds, forcing exit.

I do not know what happens, I already gave refresh in console and tried more than 5 times and nothing, i also tried another one but it didn’t work, the same error happened if someone knows please help me !!!

Here i share the repositories for them to try and if it works for them, share it to make a remix.


1 Like

Hey @H4KDev,

Welcome to the Glitch Forums! Yes, this issue was noticed yesterday by another user (see I heve a problem creating a new glitch project using a git repo!) and git cloning did not work. I’ve already pinged @support_staff once but they haven’t responded and they will soon respond. Until then, we’ll have to wait. I also tried cloning the repos you mentioned in the post, but they didn’t work either.

Hi There,

I had the same problem when I want to clone a github project from the home project by clicking
Create Project and selecting cloning from github

So the solution is when it will create the project, it will be empty so what you have to do?

  1. You go down to Tools
    image

  2. Then Click On
    image

  3. After That you click
    image

  4. It will tell you to write the following user/repo:path so you only have to put is user/repo and it is fine Like HeemPlayz/Glitch-Project (Note: You must not mistake any letter, like the capital must be capital and so)

I hope it works for you as it worked for me

2 Likes

Yes! That’s true! I completely forgot about that! Thanks @HeemPlayz!

@H4KDev,

Thanks for your report! Our team is looking into this now. I’ll provide an update once it is fixed.

1 Like

Hello!

This bug has been fixed. You should now be able to use the ‘Clone from Git Repo’ option in the ‘New Project’ drop-down menu.

If it still does not work for you, please let us know!

1 Like

Thanks for letting us know!
-Happy Glitching tech_dude1

1 Like